[Testing] [OLPC New Zealand] Auckland Testing Summary 18 June 2011

Tom Parker tom at carrott.org
Sun Jun 19 06:37:37 EDT 2011

On Sat, 2011-06-18 at 11:44 +0100, Daniel Drake wrote:

> > Could not create wireless network on either XO-1 or XO-1.5. I think
> > http://bugs.sugarlabs.org/ticket/2488 is no longer relevant – colours
> > are no longer recovered from adhoc network names.
> What was the issue here? What happens when you try to create a network?

I couldn't find the tool to create the network -- it used to be in the
context menu on the network thing in the frame, but there was nothing
there this time. Since the XO-1.5 had the 1, 6, 11 icons, I'm assuming
that it doesn't have the "xo-name's network xxxxx" feature anymore,
where the colour of the xo was encoded at the end of the name and then
badly parsed.

> > Measure seems not to suffer from http://bugs.sugarlabs.org/ticket/2509
> > on ivy, but still measures garbage on tank. Tank is an XO-1.5 C2 could
> > this be a prototype hardware problem? We only have one production XO 1.5
> > so can't check more of those.
> Yes, it could be. In general we don't place too much trust in feedback
> from non-production machines. You could apply to the contributors
> program for another XO-1.5 to help here.

I'm surprised that ticket hasn't been closed as cannot reproduce then,
unless it really has been fixed recently on production hardware.

> > Memorize – played the three preloaded games, created one basic word game
> > which successfully loaded. Did not test collaboration due to previous
> > failures with collaboration.
> As in, failures with previous builds?
> We've done quite a bit of work in this area, if you're biasing
> yourself because of previous reports it would be worth restesting. I
> don't think we have any known memorize collaboration issues right now.

Really?? We've never had any significant luck with collaboration. It
nearly always fails right at the beginning or with some kind of
incoherence or complete disconnection after a while. We'll re-test if
you guys have improved things. Do the improvements fix "everything" or
are there specific areas or scenarios that you believe now work?

We are also planning to resurrect our school server, so we can test
collaboration with and without.

> One minor point: when mentioning build numbers in mails/tickets (e.g.
> "os23") please also write the stream name, i.e. "11.2.0 build 23".
> It's obvious right now, but would be a bit confusing looking back in
> future, because build numbers get reset to zero for new streams, so it
> would not be immediately obvious that you are talking about 11.2.0.

You're right it's confusing! Why don't you include the "stream" name in
the about this xo dialog? That is generally where we go to read the
version number.

More information about the Testing mailing list