[Testing] Auckland Testing Summary 18 June 2011

Walter Bender walter.bender at gmail.com
Sat Jun 18 07:23:25 EDT 2011

On Sat, Jun 18, 2011 at 6:44 AM, Daniel Drake <dsd at laptop.org> wrote:
> On 18 June 2011 05:25, Fabiana Kubke <mf.kubke at gmail.com> wrote:
>> Present: Nevyn, Fabiana, Tabitha, Tom, Gingernut
> Thanks for the testing and great feedback. I've closed some tickets
> based on your report:
> http://dev.laptop.org/ticket/10643
> http://dev.laptop.org/ticket/10643
> In future I'll try and do a better job of communicating specific areas
> we're waiting for testing on (more specifically, confirmation of fixes
> like the above), but at the same time we do benefit from your fresh
> and unbiased/uninfluenced approach to testing the software so please
> be careful not to limit yourselves to only the things we flag up :)
>> Write: Italics, bold, underline, list formats, copy/paste, undo/redo, font
>> size, zoom in and out, insert picture and resize, insert table, insert image
>> in table, type text in table, headings, all ok.  All fonts seem to load ok.
>> Cannot see a difference between heading 3 and heading 4 format.
> Filed as http://bugs.sugarlabs.org/ticket/2904
>> Help: seems to be for a xo1. Some functions (eg, the scrolling that you get
>> by pressing the key with the hand and the trackpad) are not described.
>> The central top key that has a series of circles: not clear what that does -
>> in some instances it brings up the frame, other times it takes me to the
>> circle view. Couldn't figure out, and could not find information in the help
> Known issues:
> Help is outdated (I think you can update the content on
> flossmanuals.net like a wiki if you're interested?)
> You're hitting the keybindings for the XO-1.5 high school keyboard on
> the circle keys:
> http://wiki.laptop.org/go/OLPC_English_Non-membrane_Keyboard
> It would be ideal for those not to trigger on the "membrane" keyboards
> of course, and we have a ticket for that:
> http://dev.laptop.org/ticket/10534
>> Wikipedia-en: Two items in the portal page (Elements and Mass Media) link to
>> an unexisting page (the try again window). All the rest link ok and target
>> pages look ok except for the page "Europe" where there is text falling off
>> the infobox.
> Filed as http://bugs.sugarlabs.org/ticket/2905
> and http://bugs.sugarlabs.org/ticket/2906
>> Could not create wireless network on either XO-1 or XO-1.5. I think
>> http://bugs.sugarlabs.org/ticket/2488 is no longer relevant – colours
>> are no longer recovered from adhoc network names.
> What was the issue here? What happens when you try to create a network?
>> Measure seems not to suffer from http://bugs.sugarlabs.org/ticket/2509
>> on ivy, but still measures garbage on tank. Tank is an XO-1.5 C2 could
>> this be a prototype hardware problem? We only have one production XO 1.5
>> so can't check more of those.
> Yes, it could be. In general we don't place too much trust in feedback
> from non-production machines. You could apply to the contributors
> program for another XO-1.5 to help here.
>> About me has a new colour icon picker, it is quite strange and confusing
>> as to what colours you have picked
> CCing Walter, who designed/implemented this.

Here is how it works:

the two XOs on the left cycle through different fill colors, keeping
the stroke color constant;
the two XOs on the right cycle through different stroke colors,
lkeeping the fill color constant;
the XO in the center is the current selection -- what you'll get when you exit.

(There are two XOs for fill and two XOs for stroke so that you can
cycle back and forth in two directions -- i.e., undo.)

If you have suggestions as to how to make this less confusing, please
let me know.



>> keyboard model selection is blank by default in the top drop down even
>> though it has “olpc membrane” as an option. Keyboard layout says Akan
>> and Akan, Ghana which are top of the list –seems you should pick your
>> language there. Keys to change layout says alt+capslock but I dont think
>> we have a capslock on an XO do we? Changes do not require a restart.
> As you've noticed this dialog is a bit broken and quite
> OLPC-inappropriate, we're removing it in the next build.
> http://dev.laptop.org/ticket/10631
>> Speak video chat says we are in offline mode even though we are not and
>> can see other XO and can write to each other successfully. Robot doesnt
>> know anything at all and some replies are not even in English.
> Robot is a bit weird like that. I filed a ticket for the sharing
> issues: http://bugs.sugarlabs.org/ticket/2907
>> Maze did not share very well, kept closing on both Xos.
> Can you gather logs from this from after the crash? You'll find them
> in /home/olpc/.sugar/default/loigs
>> Memorize – played the three preloaded games, created one basic word game
>> which successfully loaded. Did not test collaboration due to previous
>> failures with collaboration.
> As in, failures with previous builds?
> We've done quite a bit of work in this area, if you're biasing
> yourself because of previous reports it would be worth restesting. I
> don't think we have any known memorize collaboration issues right now.
> One minor point: when mentioning build numbers in mails/tickets (e.g.
> "os23") please also write the stream name, i.e. "11.2.0 build 23".
> It's obvious right now, but would be a bit confusing looking back in
> future, because build numbers get reset to zero for new streams, so it
> would not be immediately obvious that you are talking about 11.2.0.
> Thanks! Very happy to be seeing this feedback :)
> Daniel

Walter Bender
Sugar Labs

More information about the Testing mailing list