[Server-devel] fresh 0.6 install

Jerry Vonau jvonau at shaw.ca
Thu Oct 1 15:27:16 EDT 2009

On Thu, 2009-10-01 at 14:15 -0400, Tim Moody wrote:
> Here are some comments on a fresh install of 0.6d5.  (Some things go by 
> quickly so it is hard to record them.)
> There was a complaint about /var/lib/pgsql/data missing.
> There was a complaint about upgrading moodle.

That should be fixed with the latest moodle-xs, but that is not on the
iso, atm... You should boot in single mode and start the network to get
internet access. Then do a yum --enablerepo=olpcxs-testing update to
grab the latest packages.

> The release notice says 9-0.5.2, but I'm pretty sure is was 0.6d5 and 
> xs-config on disk is
> Says to run network_config and domain_config before dhcp will work.  The box 
> has 3 nics, but the 2nd one, for attachment to an AP, was not connected at 
> the time of the install and first boot.
What is the third nic for, anyway?

So, the XS that is pre-configured to have the AP on "eth1", part of
lanbond0, but eth1 was not present at install time, perfect..

What is the output of:
cat /etc/udev/rules.d/70-persistent-net.rules

You can swap eth1 and eth2 in that file to rename the interfaces, if
eth1 is not the nic to your AP.

Stop the network before you edit, then reboot after your done editing.. 

> Says no domain so can't start ejabberd.  I take it this is the instruction 
> at http://wiki.laptop.org/go/XS_Installing_Software to Set the fully 
> qualified hostname of the machine by editing /etc/sysconfig/network.
After the "yum update" that should not be required.

> I then connected a non-WAN port of the AP to eth1 and rebooted.  Still no 
> dhcp.  service dhcpd status again tells me to run network_config and 
> domain_config  (I take it these are the ones in 
> /etc/sysconfig/olpc-scripts.)  I also tried eth2.
> edited /etc/sysconfig/network as indicated.
> ran network_config and domain_config  ( though 
> http://wiki.laptop.org/go/XS_Installing_Software says this is not longer 
> necessary)
> this changed HOSTNAME to schoolserver.random.xs.laptop.org, 

What did you pass to domain_config as the domain name? If you leave it
blank you get the default of "schoolserver.random.xs.laptop.org"

> but still no 
> dhcp; same message about running network_config and domain_config .

What is the output of: 

cat /etc/sysconfig/xs_server_number 
cat /etc/sysconfig/xs_domain_name
cat /etc/sysconfig/xs_network_config

> rebooted
> ejabberd still says domain not yet configured
> dhcp still asks me to run network_config and domain_config

need above info,


More information about the Server-devel mailing list