[Server-devel] fresh 0.6 install

Tim Moody timmoody at sympatico.ca
Thu Oct 1 14:15:28 EDT 2009

Here are some comments on a fresh install of 0.6d5.  (Some things go by 
quickly so it is hard to record them.)

There was a complaint about /var/lib/pgsql/data missing.
There was a complaint about upgrading moodle.
The release notice says 9-0.5.2, but I'm pretty sure is was 0.6d5 and 
xs-config on disk is

Says to run network_config and domain_config before dhcp will work.  The box 
has 3 nics, but the 2nd one, for attachment to an AP, was not connected at 
the time of the install and first boot.

Says no domain so can't start ejabberd.  I take it this is the instruction 
at http://wiki.laptop.org/go/XS_Installing_Software to Set the fully 
qualified hostname of the machine by editing /etc/sysconfig/network.

I then connected a non-WAN port of the AP to eth1 and rebooted.  Still no 
dhcp.  service dhcpd status again tells me to run network_config and 
domain_config  (I take it these are the ones in 
/etc/sysconfig/olpc-scripts.)  I also tried eth2.

edited /etc/sysconfig/network as indicated.
ran network_config and domain_config  ( though 
http://wiki.laptop.org/go/XS_Installing_Software says this is not longer 
this changed HOSTNAME to schoolserver.random.xs.laptop.org, but still no 
dhcp; same message about running network_config and domain_config .


ejabberd still says domain not yet configured
dhcp still asks me to run network_config and domain_config

> Message: 3
> Date: Thu, 1 Oct 2009 15:54:47 +0200
> From: Martin Langhoff <martin.langhoff at gmail.com>
> Subject: Re: [Server-devel] XS upgrade
> To: Henry V?lez Molina <henry.laptop at gmail.com>
> Cc: server-devel at lists.laptop.org
> Message-ID:
> <46a038f90910010654p4985ceadycfde8f247262e829 at mail.gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1
> 2009/9/29 Martin Langhoff <martin.langhoff at gmail.com>:
>> and then restart... with the restart, moodle should get started 
>> correctly...
> I have been playing with upgrades of 0.5.2 to 0.6 today and found a
> problem in the Moodle upgrade.
> Now fixed, and published as a new moodle-xs package. If Moodle was
> getting stuck, upgrade it, and "start" it (/etc/init.d/moodle start) .

More information about the Server-devel mailing list