[Server-devel] shared roster optimisation

Dafydd Harries dafydd.harries at collabora.co.uk
Fri Mar 7 15:32:50 EST 2008

Ar 05/03/2008 am 22:12, ysgrifennodd Dafydd Harries:
> Ar 05/03/2008 am 21:18, ysgrifennodd Dafydd Harries:
> > Ar 05/03/2008 am 16:17, ysgrifennodd Dafydd Harries:
> > > Ar 04/03/2008 am 21:27, ysgrifennodd Christophe Romain:
> > > > this is a path problem, erlang do not find the beam files
> > > > see the -pa argument and check it points your ejabbers ebin directory
> > > 
> > > It seems the RPM is installing two ejabberdctl files. One is in /usr/bin and
> > > is a symlink to a binary "consolehelper" executable. The other is a shell
> > > script in /usr/sbin which invokes erl. That script definitely had the wrong
> > > ebin path, but changing it from /var/lib/ejabberd/ebin (which doesn't exist)
> > > to /usr/lib/ejabberd-2.0.0/ebin (which does) doesn't seem to fix anything.
> > 
> > Does the /usr/lib path look sane? Certainly there are a bunch of .beam files
> > in it in this installation.
> > 
> > My backup plan was to stick with beta1 and update the patches, but it seems
> > that the patches to make ejabberd build with Erlang 12b don't apply to that
> > version. I don't really understand how it was building for Rob without these
> > patches though.
> To clarify, the patch in question is the one from
> https://support.process-one.net/browse/EJAB-446. It turns out that it was just
> context changes making it not apply, which was easy to fix. However, I still
> have the "init terminating in do_boot" problem. This is with a package that
> has what I believe are minimal changes from the one that Rob has to make it
> build. (I'm not sure how he built it, but I can't reproduce it.)
> Help in debugging this would be greatly appreciated. It's quite urgent as we
> would like to deploy the Jabber server in schools in Peru in the near future.
> CCing the OLPC server-devel list so that people know what's going on.

I tried rebuilding it on jabber.laptop.org, which has an olderversion of
erlang. Now I get different results:

$ ejabberdctl ejabberd start
RPC failed on the node ejabberd at jabber: nodedown

If epmd is already running, it gives this message quickly. Otherwise, it takes
a long time, and I still get this message, but epmd is running when it
finishes, and it's accepting connections.


More information about the Server-devel mailing list