[OLPC-SF] Trouble trying to upgrade a very old OLPC XO ...

Joachim Pedersen joachimp at gmail.com
Sat Nov 20 22:57:17 EST 2010

Please see the instructions here:
the short:
You need a usb drive that is at least 1GB, and you need to download two files

best of luck-
olpc-sf repair

On Sat, Nov 20, 2010 at 19:42, Krishnan R.S. <rskrishnan at hotmail.com> wrote:
> Hello,
>    I managed to get my hands on a very old OLPC XO laptop for my daughter.
> I've been trying, unsuccessfully, to upgrade the OS to something current.
> The main issues are:
> My image has no olpc-update
> I tried to follow the wiki instruction to update olpc-update - alas that
> leads to more issues about missing python2.5
> I tried to install python using apt/deb/dpkg but all of these fail since the
> apt/deb/dpkg tools are missing :(
> Looking at /etc/issue - I see build 417 - and some messages that look like
> errors "kernel \r \m ...." :) so maybe I have a pre-alpha build :)
> After trying the above now I can't seem to be able to boot into 'X' on the
> XO - it just keeps looping looking for something - I've most likely made a
> bad situation worse :(
> So ... I'm somewhat at a loss as to what my next steps are. My daughter
> seems pretty excited with the device and enjoys the "paint" application. I'd
> like to get a more recent build so she can use the newer apps/toos.
> Can you point me in the right direction ? Or am I wasting my time trying to
> do the impossible?
> Or if someone could send me a list of things to check/verify - so we can see
> if it can be upgraded or not.
> Thanks,
> Krishnan
> --
> Krishnan Subramaniam
> rskrishnan at hotmail.com
> _______________________________________________
> OLPC-SF mailing list
> OLPC-SF at lists.laptop.org
> http://lists.laptop.org/listinfo/olpc-sf

More information about the OLPC-SF mailing list