[OLPC-SF] Trouble trying to upgrade a very old OLPC XO ...

Krishnan R.S. rskrishnan at hotmail.com
Sat Nov 20 22:42:36 EST 2010

 I managed to get my hands on a very old OLPC XO laptop for my daughter.
 I've been trying, unsuccessfully, to upgrade the OS to something 
current. The main issues are:My image has no olpc-updateI tried to follow the wiki instruction to update olpc-update - alas that leads to more issues about missing python2.5I tried to install python using apt/deb/dpkg but all of these fail since the apt/deb/dpkg tools are missing :(Looking
 at /etc/issue - I see build 417 - and some messages that look like 
errors "kernel \r \m ...." :) so maybe I have a pre-alpha build :)After trying the above now I can't seem to be able to boot into 'X' on the XO - it just keeps looping looking for something - I've most likely made a bad situation worse :(

 ... I'm somewhat at a loss as to what my next steps are. My daughter 
seems pretty excited with the device and enjoys the "paint" application.
 I'd like to get a more recent build so she can use the newer apps/toos.Can you point me in the right direction ? Or am I wasting my time trying to do the impossible?

Or if someone could send me a list of things to check/verify - so we can see if it can be upgraded or not.



Krishnan Subramaniam

rskrishnan at hotmail.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.laptop.org/pipermail/olpc-sf/attachments/20101120/9b75f104/attachment.htm 

More information about the OLPC-SF mailing list