[Etoys] Stuff to do for Sugar release 0.84

Milan Zimmermann milan.zimmermann at sympatico.ca
Mon Apr 6 00:41:06 EDT 2009

I did quite a bit more application testing (etoys) in 0.84. It looks very good 
to me overall. I did notice a few things that are etoys related, Some I could 
not duplicate though:

Reported etoys items
	- [Etoys-Sugar-0.84-OLPC] Soas-2009040110. Played on OLPC from a stick. In 
morph menus, missing "export" menu item between "siblings" and "extras". This 
is interesting because this item does exist in the Etoys 4.0 image downloaded 
from Tinlizzie http://tinlizzie.org/olpc/etoys-dev-40.zip.

	- [Etoys-Sugar-0.84-OLPC] Soas-2009040110. Played on OLPC from a stick. 
Object Catalog->Multimedia->Camera does not show anything. This may be a 
problem with Sugar, not Etoys. 

	- [Etoys-Sugar-0.84-OLPC] Soas-2009040110. Played on OLPC from a stick. No 
sound .using either -vm-sound-OSS or vm-sound-ALSA in /usr/bin/etoys. This 
seems problem with Sugar, not Etoys. The driver is loaded yet I do not hear 
any sound in any Sugar activities.

	- I agree a Home button is needed. Already reported by Bert/Scott. 

Unreported etoys items (could not produce steps to duplicate)

	- had a weird problem when renaming projects in the Sugar. (red name over 
another project black name)

	- Event Theatre, when recording complex process that included long script 
building, did not replay correctly. Must have missed some events along the 
Bert, I have a few more notes below inline.

On April 3, 2009, Bert Freudenberg wrote:
> On 03.04.2009, at 08:36, Milan Zimmermann wrote:
> > ok, after fighting with virtualbox emulation (and eventually giving
> > up), and incomplete SuSE Sugar version (also gave up, thanks Bert
> > for suggestions there), I am testing Etoys in Sugar 0.84 installed
> > on a stick right on the OLPC XO.
> Yay!


> > Over all Etoys on 0.84 look good, but I will have to do more testing
> > this weekend, so far I see:
> >
> > Sugar Interaction Problems
> > ====================
> >
> > - If there are any Etoys activities in the Journal, the last actvity
> > is picked up when I start Etoys from the menu Circle. This way, I
> > can never see Etoys initial screen. I think this is what Bert
> > mentioned. It is really annoying behavior, I assume it changed
> > because of some changes in the Sugar container. This is really the
> > only item I would (personally) consider a bad bug / behaviour. Can
> > anyone make a rough comment what would need to be done to change this?
> Well, you can still open a fresh Etoys instance from the activities
> screen by moving your mouse to the Etoys icon, do not click but wait
> until the little black label appears, do still not click but wait
> until the label expands to a menu, and then click the "start" menu item.
> But this is rather awkward, indeed. The best idea so far was to have a
> "home" button that would take you to the launcher screen:
> https://dev.laptop.org/ticket/9282

yes, I agree this is a good addition to Sugar version after the changes.

> > - Etoys do not have Ctrl-Q / Ctrl-S for Quit / Save on the top right
> > Controls.
> Not quite sure what you mean hear ...

I ment  to say other Activities seems to have a Ctrl-Q shortcut for the "Stop" 
button and Ctrl-S to "Keep".

> > - In shared mode, on the "network screen", Etoys is listed as
> > "Gallery" (very minor)
> Interesting ... it used to show "/usr/share/etoys/etoys.image":
> https://dev.laptop.org/ticket/8251

actually it now shows the etoys project name which is reasonable. So maybe the 
bug can be closed. I looked at it when I worked with the Gallery of projects.

> > - when not connected to the network, and switching to shared mode, a
> > DBus Error Debug Screen appears.
> That should be handled nicer indeed.
> > - There is no sound - but I think there is be no sound on the OLPC
> > running 0.84 from the stick
> That might very well be this problem:
> 	http://bugs.squeak.org/view.php?id=7328
> If so, a workaround would be to switch to OSS in the /usr/bin/etoys
> script (add -vm-sound-OSS to the VM options).

I tried both OSS and ALSA, but none worked. The sound driver (ac97) is loaded 
but I have not heard any sound from any activity onnthe XO, including the 
speach activity. So I speculate it is Sugar 0.84 related. Documented in a bug 
just in case - 

> > >
> > Etoys Problems (very little Etoys specific testing so far):
> > ============
> >
> > - sound does not work(Sugar/OLPC Hardware at fault?)
> See above
> > - video does not work(?Sugar/Hardware at fault?)
> For GStreamer you need a new VM, too. I think that's the only video
> option we have on Linux.

Where can I get the new VM .. I guess it is time to learn how to do that...

> > >
> - Bert -


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.laptop.org/pipermail/etoys/attachments/20090406/a84f33ff/attachment.htm 

More information about the Etoys mailing list