[Etoys] problems with event recorder and event theater

Scott Wallace scott.wallace at squeakland.org
Thu Apr 19 15:17:59 EDT 2007

Thanks, Phil,

Yes, the "file dialogs" are problematical for the Event Theatre,  
which transforms coordinates for playback so that they bear the same  
positions relative to the top-left corner of the playback theatre as  
they had borne to the top-left corner of the originating recording  
theatre; this works well for almost everything, but for the "standard- 
file dialogs" it falls apart because such dialogs are positioned  
relative to the screen-center rather than relative to the theatre- 
location.  So mouse clicks made within a file-dialog upon recording  
will tend to play back as clicks somewhere else on the screen, with  
potentially bizarre consequences.

This is potentially a hard problem.  Until it gets resolved, I think  
it's probably best not to include any use of the file-dialogs in your  
event recordings.

Thank you for alerting us to this issue!  Sorry not to have an  
immediate solution up our sleeves.


   -- Scott

Begin forwarded message:

> From: Phil Dawson <phil_dawson_2000 at yahoo.com>
> Date: April 19, 2007 5:27:58 AM PDT
> To: Scott Wallace <scott.wallace at squeakland.org>
> Subject: Re: [Etoys] problems with event recorder and event theater
> Yes, the problem happens every time I use find any
> file.  The reason I ran into this is because I was
> trying to make a recording of this tutorial
> http://wiki.laptop.org/go/BookMorph_Tutorial
> --- Scott Wallace <scott.wallace at squeakland.org>
> wrote:
>> Thank you, Phil!
>> Could it be true that *every* time you've
>> encountered this kind of
>> problem, it's involved use of a "file dialog" (find,
>> find-any-file,
>> or publish-it) within an event-recording?
>> Cheers,
>>    -- Scott
>> On Apr 18, 2007, at 6:41 PM, Phil Dawson wrote:
>>> Hi Scott,
>>> I am running etoys-dev-2.0-1217 on open suse 10.2
>>> I am trying to record the process of importing a
>>> photo.  The recording process seems to mess up
>> when I
>>> go to find any file and select the file name of
>> the
>>> picture.  Every thing done after that is ether not
>>> recorded correctly or it just does not playback
>>> correctly.  I just tried it today with the latest
>>> patches and I am havening the same problem.  I
>> have
>>> attached a .pr for you to look at.
>>> Thanks
>>> Phil Dawson
>>> --- Scott Wallace <scott.wallace at squeakland.org>
>>> wrote:
>>>> Hi, Phil,
>>>> I've not seen this problem, and so far no one
>> else
>>>> has reported it,
>>>> so it has been hard to investigate it further.
>>>> So -- assuming you're still encountering it --
>>>> please help us track
>>>> this problem down...
>>>> * What *platform* are you operating on?  (Actual
>> XO
>>>> machine?)
>>>> * Please describe, as precisely as possible, a
>> short
>>>> sequence you've
>>>> recorded whose playback exhibits the problem.
>>>> * If possible, please enclose a ".pr" file that
>>>> illustrates the problem.
>>>> Getting "off registry" has always been a big
>>>> potential problem with
>>>> the Event Recorder.  Since an event-recorder
>> "tape"
>>>> consists
>>>> primarily of nothing more than time-stamped mouse
>>>> events, with
>>>> absolute x-y coordinates, as soon as there is any
>>>> disparity between
>>>> locations of any objects at the time of the
>>>> recording and at the time
>>>> of playback, there's the potential for
>> malfunction.
>>>> The motivation
>>>> for the "Event Theatre" (as opposed to the bare
>>>> EventRecorder) was
>>>> specifically to minimize such problems by
>> assuring
>>>> that recording and
>>>> playback take place in circumstances that are
>> made
>>>> to be compatible.
>>>> If there's really a bug here, we need to catch
>> it.
>>>> So hopefully you,
>>>> or perhaps some other readers of this list, can
>> help
>>>> us isolate it.
>>>> Sorry nobody got back to you sooner on this.
>>>> Cheers,
>>>>    -- Scott
>>>> On Apr 8, 2007, at 4:58 PM, Phil Dawson wrote:
>>>>> Hello Everyone,
>>>>> While trying to make some "How to" projects
>> using
>>>> the
>>>>> event recorder or the event theater I run into
>> the
>>>>> same problem.  While the record function seams
>> to
>>>> be
>>>>> working when I play back the recording it will
>>>> start
>>>>> off fine and then start showing commands that I
>>>> did
>>>>> not select and eventually everything it shows is
>>>>> wrong.  I am useing etoys-dev-2.0-1217 with the
>>>> latest
>>>>> updates.  I am not sure but I thought the
>>>> recording
>>>>> functions were working before the large cursor
>>>> update
>>>>> was added.
>>>>> Phil Dawson

More information about the Etoys mailing list