intermittent keyboard mismapping: 13.2.5 on XO-1 SKU39

Adam Holt holt at
Wed Aug 5 02:00:43 EDT 2015

Summary: while both 13.2.5 OS's for XO-1 SKU39 (and possibly similar SKU's)
have a couple keyboard/mouse issues, arising from q2f20's EC firmware it
seems -- the workaround to both issues appears very simple -- simply do not
to touch the keyboard during these 2 critical moments:

   - during the first few seconds after powering on (hit/hold ESC key
   _after_ the XO kid appears in the center of your screen, if seeking the ok
   prompt on an unlocked XO)
   - when the XO is sleeping

Yes there's now also a bulletproof workaround to the 1st issue (keyboard
mismapping if ESC is tapped too early during bootup) if you downgrade
firmware from q2f20 to which
includes EC Firmware E35, dated 2010-08-23.  Wonderful that James Cameron
isolated the problem.

But this fix might not be worth the trouble, as keyboard+mouse variously go
haywire after sleep/wake -- up particularly if you touch the keyboard while
XO's sleeping -- regardless which of these 2 firmwares.

Regardless, folks need to retrain (refrain) themselves on when to hit ESC
on bootup:

Conclusion: I'm not educated enough to know whether q2f20 or q2f20ed is
best for one deployment or another.  Sticking with 13.2.5's stock firmware
q2f20 (including EC Firmware 1.2.1) might well be easiest for many,
certainly for now, sure the above 2 workarounds to require training, but
both appear 100% effective so far.  Or if you do choose to downgrade to
q2f20ed, note the 4 small accompanying regressions/risks below, and judge
for yourself:

- you lose a fix for mouse activity at shutdown preventing reboot without

- you lose a fix for battery EEPROM corruption, which happens if you are
holding the power button down and insert the battery,

- you lose the AP (Auto Power) and CP (Constant Power) features for use as
a server, and;

- you lose RTC anti-rollback support, which you shouldn't be using anyway.

Most important, let's all be very helpful James Cameron carefully explained
the above tradeoff- whether XO-1 live forever or not as we shall see :-)

On Tue, Aug 4, 2015 at 9:28 AM, Adam Holt <holt at> wrote:

> Just an update that I've narrowed in on the/a pattern which triggers the
> problem, with the help of James Cameron, and some workarounds:
>    - Tapping the ESC key very rapidly during bootup causes the keyboard
>    mismapping (and hence, failure to enter Open Firmware).
>    - Holding down the ESC key during bootup (generally, but not always)
>    avoids the problem (entering Open Firmware).
>    - Typing no keys at all during initial bootup, appears (I hope) to be
>    a workaround to boot the OS properly, with keyboard functioning properly.
> Better yet, earlier firmware (e.g. q2e41 in this case) does not appear to
> show the problem at all, so newer firmware may be available in future to
> solve this annoying-but-less-serious-that-I-imagined problem.  For all
> using SKU39 XO-1s (or perhaps other/similar XO laptops having the modern
> touchpad?)
> On Mon, Aug 3, 2015 at 7:03 PM, Adam Holt <holt at> wrote:
>> I haven't figured out the pattern yet, but perhaps 50% of the time these
>> XO-1s boot with an unusable keyboard (it's a "US Intl" keyboard, but the
>> keys end up mapped to all the wrong places, showing the wrong
>> letters/numbers, such that not even the ESC key works to get to the Ok
>> prompt).
>> This pattern arises with "vanilla" 13.2.5 (without SD cards) as well as
>> 13.2.5 with SD cards.  In other words both of these:
>> Running the "bye" command at the Ok prompt seems to trigger the problem
>> almost every time (possibly every time?).  But that is not the only thing
>> that triggers the problem.  Sometimes the XO just boots with unusable
>> keyboard, repeatedly.  Then when I try to hit ESC on boot 20 times in a
>> row, I cannot reproduce the problem at other times.  Problem occurs on all
>> SKU39 XO-1s I've tried so far.
>> I've not yet tried other SKU's.  My testing has only just begun, to see
>> if this same problem occurs with (both) 13.2.4 OS's and earlier.
>> Any tips for debugging / identifying the source of this quite serious
>> gremlin?  What should I and my small team of debugging volunteers look out
>> for and try?  And I'll do more work on this when I get back home late
>> tonight, but all thoughts appreciated-
>> (Also, any recommendations as to which older builds are best, as an
>> interim workaround?)
>> --
>> Unsung Heroes of OLPC, interviewed live @ !

Unsung Heroes of OLPC, interviewed live @ !
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list