[support-gang] intermittent keyboard mismapping: 13.2.5 on XO-1 SKU39

James Cameron quozl at netrek.org
Wed Aug 5 00:54:15 EDT 2015

Yes, it almost never happens for a child, has been known since
2011, is specific to the single panel touchpad assembly on XO-1, and
is solved by following (to the letter) our community documentation:


... instead of historic practices that were learned on the three panel
touchpad assembly.  ;-)

On Tue, Aug 04, 2015 at 09:28:23AM -0400, Adam Holt wrote:
> Just an update that I've narrowed in on the/a pattern which triggers the
> problem, with the help of James Cameron, and some workarounds:
>   • Tapping the ESC key very rapidly during bootup causes the keyboard
>     mismapping (and hence, failure to enter Open Firmware).
>   • Holding down the ESC key during bootup (generally, but not always) avoids
>     the problem (entering Open Firmware).
>   • Typing no keys at all during initial bootup, appears (I hope) to be a
>     workaround to boot the OS properly, with keyboard functioning properly.
> Better yet, earlier firmware (e.g. q2e41 in this case) does not appear to show
> the problem at all, so newer firmware may be available in future to solve this
> annoying-but-less-serious-that-I-imagined problem.  For all using SKU39 XO-1s
> (or perhaps other/similar XO laptops having the modern touchpad?)
> On Mon, Aug 3, 2015 at 7:03 PM, Adam Holt <[1]holt at laptop.org> wrote:
>     I haven't figured out the pattern yet, but perhaps 50% of the time these
>     XO-1s boot with an unusable keyboard (it's a "US Intl" keyboard, but the
>     keys end up mapped to all the wrong places, showing the wrong letters/
>     numbers, such that not even the ESC key works to get to the Ok prompt).
>     This pattern arises with "vanilla" 13.2.5 (without SD cards) as well as
>     13.2.5 with SD cards.  In other words both of these:
>        [2]http://wiki.laptop.org/go/Release_notes/13.2.5#XO-1
>        [3]http://wiki.laptop.org/go/Release_notes/13.2.5#XO-1_with_SD_card
>     Running the "bye" command at the Ok prompt seems to trigger the problem
>     almost every time (possibly every time?).  But that is not the only thing
>     that triggers the problem.  Sometimes the XO just boots with unusable
>     keyboard, repeatedly.  Then when I try to hit ESC on boot 20 times in a
>     row, I cannot reproduce the problem at other times.  Problem occurs on all
>     SKU39 XO-1s I've tried so far.
>     I've not yet tried other SKU's.  My testing has only just begun, to see if
>     this same problem occurs with (both) 13.2.4 OS's and earlier.
>     Any tips for debugging / identifying the source of this quite serious
>     gremlin?  What should I and my small team of debugging volunteers look out
>     for and try?  And I'll do more work on this when I get back home late
>     tonight, but all thoughts appreciated-
>     (Also, any recommendations as to which older builds are best, as an interim
>     workaround?)
>     --
>     Unsung Heroes of OLPC, interviewed live @ [4]http://unleashkids.org !
> References:
> [1] mailto:holt at laptop.org
> [2] http://wiki.laptop.org/go/Release_notes/13.2.5#XO-1
> [3] http://wiki.laptop.org/go/Release_notes/13.2.5#XO-1_with_SD_card
> [4] http://unleashkids.org/

> _______________________________________________
> support-gang mailing list
> support-gang at lists.laptop.org
> http://lists.laptop.org/listinfo/support-gang

James Cameron

More information about the Devel mailing list