Fwd: Re: [support-gang] intermittent keyboard mismapping: 13.2.5 on XO-1 SKU39

Adam Holt holt at laptop.org
Tue Aug 4 20:29:28 EDT 2015

---------- Forwarded message ----------
From: "James Cameron" <james at tooraweenah.com>
Date: Aug 4, 2015 7:39 PM
Subject: Re: [support-gang] intermittent keyboard mismapping: 13.2.5 on
XO-1 SKU39
To: "Gonzalo Odiard" <gonzalo at sugarlabs.org>
Cc: "Community Support Volunteers -- who help respond to help AT laptop.org"
<support-gang at lists.laptop.org>, "Danny Hembree" <
danny-hembree at dynamical.org>, "gluna at goodshepherdshelter.org" <
gluna at goodshepherdshelter.org>, "Devel's in the Details" <devel at laptop.org>

G'day Gonzalo,

Thanks for the reminder.  Yes, it matches somewhat with #11223 and
#11468, especially the mapping of the keys that Adam observes.


No fix is possible at the moment, but changing procedure works fine.

p.s. my posts are not getting through to devel@ or support-gang@ due
to the DNS damage affecting laptop.org.

On Tue, Aug 04, 2015 at 03:17:02PM -0300, Gonzalo Odiard wrote:
> I don't think the error reported by Alan is related with the last (or
> builds at all.
> This is related to a very old bug, I was looking but couldn't find the
> Gonzalo
> On Tue, Aug 4, 2015 at 1:07 PM, Caryl Bigenho <[1]cbigenho at hotmail.com>
>     Hi…
>     So…  the XO-1s at the project we have at a school at a women's
shelter in
>     central Los Angeles will be updated in the next couple of weeks,
>     ready for September school start. What would be the safest build for
>     to use? I won't be there to help, but it is in good hands with one of
>     SoCal volunteers. I just want to make it easy for everything to go
>     smoothly.
>     Thanks,
>     Carul
>     Date: Tue, 4 Aug 2015 09:28:23 -0400
>     From: [2]holt at laptop.org
>     To: [3]support-gang at lists.laptop.org; [4]devel at laptop.org
>     Subject: Re: [support-gang] intermittent keyboard mismapping: 13.2.5
>     XO-1 SKU39
>     Just an update that I've narrowed in on the/a pattern which triggers
>     problem, with the help of James Cameron, and some workarounds:
>       □ Tapping the ESC key very rapidly during bootup causes the keyboard
>         mismapping (and hence, failure to enter Open Firmware).
>       □ Holding down the ESC key during bootup (generally, but not always)
>         avoids the problem (entering Open Firmware).
>       □ Typing no keys at all during initial bootup, appears (I hope) to
be a
>         workaround to boot the OS properly, with keyboard functioning
>     Better yet, earlier firmware (e.g. q2e41 in this case) does not
appear to
>     show the problem at all, so newer firmware may be available in future
>     solve this annoying-but-less-serious-that-I-imagined problem.  For all
>     using SKU39 XO-1s (or perhaps other/similar XO laptops having the
>     touchpad?)
>     On Mon, Aug 3, 2015 at 7:03 PM, Adam Holt <[5]holt at laptop.org> wrote:
>         I haven't figured out the pattern yet, but perhaps 50% of the time
>         these XO-1s boot with an unusable keyboard (it's a "US Intl"
>         but the keys end up mapped to all the wrong places, showing the
>         letters/numbers, such that not even the ESC key works to get to
the Ok
>         prompt).
>         This pattern arises with "vanilla" 13.2.5 (without SD cards) as
well as
>         13.2.5 with SD cards.  In other words both of these:
>            [6]http://wiki.laptop.org/go/Release_notes/13.2.5#XO-1
>            [7]
>         Running the "bye" command at the Ok prompt seems to trigger the
>         almost every time (possibly every time?).  But that is not the
>         thing that triggers the problem.  Sometimes the XO just boots with
>         unusable keyboard, repeatedly.  Then when I try to hit ESC on
boot 20
>         times in a row, I cannot reproduce the problem at other times.
>         occurs on all SKU39 XO-1s I've tried so far.
>         I've not yet tried other SKU's.  My testing has only just begun,
to see
>         if this same problem occurs with (both) 13.2.4 OS's and earlier.
>         Any tips for debugging / identifying the source of this quite
>         gremlin?  What should I and my small team of debugging volunteers
>         out for and try?  And I'll do more work on this when I get back
>         late tonight, but all thoughts appreciated-
>         (Also, any recommendations as to which older builds are best, as
>         interim workaround?)
>         --
>         Unsung Heroes of OLPC, interviewed live @ [8]
http://unleashkids.org !
>     _______________________________________________ support-gang mailing
>     [9]support-gang at lists.laptop.org [10]http://lists.laptop.org/listinfo/
>     support-gang
>     _______________________________________________
>     support-gang mailing list
>     [11]support-gang at lists.laptop.org
>     [12]http://lists.laptop.org/listinfo/support-gang
> References:
> [1] mailto:cbigenho at hotmail.com
> [2] mailto:holt at laptop.org
> [3] mailto:support-gang at lists.laptop.org
> [4] mailto:devel at laptop.org
> [5] mailto:holt at laptop.org
> [6] http://wiki.laptop.org/go/Release_notes/13.2.5#XO-1
> [7] http://wiki.laptop.org/go/Release_notes/13.2.5#XO-1_with_SD_card
> [8] http://unleashkids.org/
> [9] mailto:support-gang at lists.laptop.org
> [10] http://lists.laptop.org/listinfo/support-gang
> [11] mailto:support-gang at lists.laptop.org
> [12] http://lists.laptop.org/listinfo/support-gang

> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel

James Cameron
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20150804/d9e4a0c4/attachment.html>

More information about the Devel mailing list