[support-gang] gray dots forever: when 12.1.0 & 13.1.0 never fully boot (XO-1 especially? 11.3.1 too)

Nancie Severs olpc.dristi at yahoo.com
Mon Mar 11 12:31:57 EDT 2013

Hi Daniel!
The Support gang list has had threads on this over the past 6 months. Some things we had tried doing when I ran into it with 11.3.1 updates, was to go back to 8.2.1 or 8.3 and reflash up again. That worked in some cases, and not in others.

I had it with a brand new blue high school XO-1.5 (that booted normally before I flashed it to 12.1.0). I took that one to the Boston office & Richard Smith watched the boot and figured out the work around. Adam has it for Haiti now. I have XO-1's that do this that I can provide to someone to hook up & log as you suggest. And I have a few new 1.5's that we can try and reproduce it on also, if helpful. My point is that the problem is not limited to the XO-1s.

Richard, would it be helpful for me to bring some affected XOs down to the office if I can get to Boston later this week?

Here's more detail:

1. The first time I saw this problem was with 2 XOs that had been de-bricked and reflashed to 11.3.1, and sent out for loan for a film shoot. I got a call from the shoot that they were stuck at the grey dots. We didn't know the check boot workaround then and nothing worked. Embarrassing, but otherwise no harm done. 

My best guess: I thought that maybe it was a firmware issue because the laptops might not have been fully charged when reflashing. (Watching a reflash one day, I did see a message something about not having enough battery life to upgrade the firmware, procedding to reflash anyway.) Since then, now, I am plugging in laptops overnight before reflashing. And leaving the reflashed ones plugged in overnight again to fully charge the clock battery.

Yesterday I completed 12 with this procedure. (12 that previously had been reflashed to 11.3.1  This morning, all of these XO-1's boot without a grey dot problem. That's good news, but maybe just the luck of the draw.

Important grey dot conclusion. See below. Whether the laptop is secured or not, does not seem to matter. The secured and unsecured today all booted. 

2. (New thread but related- invalid system date) 4 of the above XOs booted with invalid system date. Each of those allowed me in at the root terminal (Ctrl Alt F2) to reset the date. It displayed the correct new date, and I shut down with sudo poweroff. When rebooting, the new date was not saved. It still says invalid system date. When trying the esc interrupted boot, I can't get to the ok prompt. The boot shows that these 4 XOs are each secured but proceed to boot. Other "secured" laptops have asked for a password at the Root Terminal. Are there different types of secured XOs? (Those 4 are now in the big pile that need developer keys.)

There are 2 XOs, reflashed as above that boot directly to the OK prompt.Is there an easy fix for that to make them boot directly to the Sugar Home View?
I hope we can soon sort these issues out, so that XO-1s many of them which are almost new, can be redistributed in conditions where they can be used. In the field, when people have these sorts of problems, they easily give up and the laptops get traded for avocados.:)


Nancie Severs

OLPC Support Volunteer

 From: Daniel Drake <dsd at laptop.org>
To: Holt <holt at laptop.org> 
Cc: IAEP <iaep at lists.sugarlabs.org>; Devel's in the Details <devel at lists.laptop.org>; Community Support Volunteers -- who help respond to help AT laptop.org <support-gang at lists.laptop.org> 
Sent: Monday, March 11, 2013 10:23 AM
Subject: Re: [support-gang] gray dots forever: when 12.1.0 & 13.1.0 never fully boot (XO-1 especially? 11.3.1 too)

On Sun, Mar 10, 2013 at 2:41 PM, Holt <holt at laptop.org> wrote:
> On 3/10/2013 3:39 PM, Nancie Severs wrote:
> Going to 12 and 13, I am still getting a % of XOs that get stuck at the grey
> dots when booting after the reflash is complete. Richard Smith figured out
> that this is a Pretty Boot issue. He had a workaround that worked on an XO
> 1.5, but I have not been successful had getting that to work on an XO 1.0.
> I've the same issue with an XO-1 running Release 11.3.1 -- it was previously
> running March 6th's 13.1.0
> Now it freezes at the end of prettyboot (once all grey dots have formed a
> circle).

I think this is the first report we have of this issue. To diagnose
further, it would be good if someone could hook up a serial console
and log the boot messages. I know it's not trivial to have this
available, but I can't think of other debugging approaches.

Also, it is always helpful to know at exactly which point the system
hangs. In Adam's case this was stated clearly (I interpret: once all
the dots in the circle go dark grey after they have 'spun around' for
a while) but in Nancie's case it wasn't.

The other thing to keep in mind is that first boot takes longer than
subsequent boot. So be sure to have a little patience before declaring
the system as hung.

support-gang mailing list
support-gang at lists.laptop.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20130311/fb3bf8d8/attachment.html>

More information about the Devel mailing list