XO-4 lack of keyboard/mouse input - still happening?

Paul Fox pgf at laptop.org
Tue Jan 29 11:28:51 EST 2013

daniel wrote:
 > Hi,
 > In recent months we have seen some issues with the XO-4 keyboard and
 > mouse, where the system would boot (or resume from suspend?) and not
 > respond to keyboard/mouse input (and/or respond to keyboard input in a
 > very lagged manner).
 > This problem may have been accompanied with kernel messages like:
 > psmouse serio1: Failed to deactivate mouse on olpc_touchpad/serio0
 > psmouse serio1: Failed to enable mouse on olpc_touchpad/serio0
 > psmouse serio1: sentelic: Unable get OPC state.
 > atkbd serio0: keyboard reset failed on olpc_keyboard/serio0
 > and corresponds to tickets:
 > #12101 cl4: touchpad missing after reboot
 > #12370 No mouse interaction possible after bootup
 > Has anyone seen these problems or the possibly-related kernel messages
 > on recent builds such as 13.1.0 build 27 with the latest firmware?
 > I previously saw it fairly regularly on my two XO-4s but I can't
 > recall seeing it recently. Additionally, we would sometimes get those
 > kernel messages during shutdown, and those messages have now gone
 > away, so I'm wondering if we have fixed these issues while working on
 > related things.

i wish i could point to an EC or kernel fix that i'm aware of that
would have made it go away, but i can't.  i agree that i don't recall
seeing it lately.

 paul fox, pgf at laptop.org

More information about the Devel mailing list