XO-1.5's sudden death - oven resurrected!

Yioryos Asprobounitis mavrothal at yahoo.com
Mon Oct 15 13:32:43 EDT 2012

--- On Mon, 10/15/12, James Cameron <quozl at laptop.org> wrote:

> From: James Cameron <quozl at laptop.org>
> Subject: Re: XO-1.5's sudden death
> To: "Yioryos Asprobounitis" <mavrothal at yahoo.com>
> Cc: "OLPC Devel" <devel at lists.laptop.org>
> Date: Monday, October 15, 2012, 2:39 AM
> Yes, I know it so well known that I
> can remember the bug number,
> #10314.  I've had four laptops do this.
> http://dev.laptop.org/ticket/10314

I had forgotten about this. Yes is the same problem.

So I tried a home bake (reflow) as originally reported by Anna [1] and specified by wad [2] and worked beautifully :-)

So here are my notes.
Used a standard household AEG electric convection oven (with the circulating air) with the fan running.

Add a tray close to the bottom and another close to the top (so will no be any direct heating)
Add 4 shut-glasses or expresso cups to support the board.
Heat the oven to 80 C.
Remove the board from the XO-1.5 [3]
Remove the RTC battery, the wifi module, the mico-SDcard and the camera (including its white plastic support that sits over the USB port).
Put the board in the oven over the glasses (cups) touching the grasses with the protruding usb, audio, etc connectors (CPU and other chips facing up) for 15min at 80C.
Remove the board. Turn up the oven to 180C. 
When it reaches the temperature for 5-10 minutes (as indicated by the thermostat light), turn the fan off (so will not cool down when you open the oven) put the board on top of the 4 glasses and turn the fan on.  
After 90sec turn the temperature of the oven up to 220C with the board in (my oven takes 3'40" to get there)
After 60sec at 220C turn the temperature up to 260C (at least 250C if your oven does not go higher)
At 9 minutes from the start of the run turn off the heat (not the fan) open oven door (the temperature in my oven was ~250C at the time) and let it cool down a bit.
Remove from the oven and cool it to room temperature (~15 min)

My only loss was the camera support plastic that I did not remove and became a nice little ball. A piece of cardboard and some double-sided adhesive tape, replaces it now in my XO. 
Passed all the hardware tests with no problem except the RTC clock that needs resetting. 
My XO-1.5 is back in business! 

[1] http://lists.laptop.org/pipermail/devel/2011-August/032908.html 
[2] http://lists.laptop.org/pipermail/devel/2011-August/032938.html
[3] http://wiki.laptop.org/images/d/d9/XO_Disasembly_%28Top%29.pdf

> On Sun, Oct 14, 2012 at 10:35:32PM -0700, Yioryos
> Asprobounitis wrote:
> > My XO-1.5 that I use daily appears dead this morning.
> :-(
> > Was working trouble free till last night (os885). 
> > Powered off normally  and this morning when
> powering up the power light comes up green, the screen
> flashes momentarily (screen lights OK I assume) and then
> nothing. 
> > No screen, no chime. nothing.
> Reset   EC, battery, power, no change. 
> > Is it something that has been seen with XO-1,5s. Is
> salvageable at this point? (other than removing the SDcard
> and snatching the other XO-1.5 from my son `;-) Is the
> booting going to stop (no chime) if the screen is dead? Can
> the serial port be used for diagnosis at this early stage if
> is not the screen?
> > Sorry if too many questions but I *use* the specific XO
> beyond testing and hacking and I hate losing it.
> > I would appreciate any guidance on the recommended
> steps to approach this.
> > Thx  
> > _______________________________________________
> > Devel mailing list
> > Devel at lists.laptop.org
> > http://lists.laptop.org/listinfo/devel
> -- 
> James Cameron
> http://quozl.linux.org.au/

More information about the Devel mailing list