XULRunner Version 1.9 Issue Reading Local Files With No Internet Connectivity

anthony at evolutionindesignz.com anthony at evolutionindesignz.com
Wed Jan 11 21:31:34 EST 2012

My understanding of characterizing a software problem is to see if 
under the same conditions the observations are repeatable.

My observations are that calling the application from the default 
installed XULRunner and attempting to use the documented browser 
object (https://developer.mozilla.org/en/XUL/browser#m-loadURI) to read 
the localhost when the OLPC is disconnected from the network results in 
odd behavior or failure to start up.

Using exactly the same code, but instead calling the application from 
XULRunner version 8.0, the code works as expected, even when the 
computer is disconnected from the network.

For the current version of the application, we will follow Chris Ball's 
recommendation to bundle the application with XULRunner version 8.0.

Future versions of the application will have to be re-written using 

On 11.01.2012 18:57, Benjamin M. Schwartz wrote:
> On 01/11/2012 04:37 PM, anthony at evolutionindesignz.com wrote:
>> With the OLPC laptop disconnected from the Internet, I try to 
>> startup
>> XULRunner and read local files using the browser tag like this:
>>   <browser type="content" src="http://localhost/myfile.html"
>> autoscroll="true" flex="1"/>
>> With XULRunner 1.9, the screen remains blank, and the file is not
>> loaded.
>> I installed XULRunner 8.0 on the OLPC laptop. I am not able to
>> replicate the problem with XULRunner version 8.0
> Your diagnosis cannot possibly be correct.  There is no reason that 
> the
> version of Xulrunner should have any effect on this.  It is much more
> likely that something else changed between your two tests.
> You should stick with the installed version of Xulrunner and figure 
> out
> what the true bug is.
> --Ben

More information about the Devel mailing list