[Techteam] 12.1.0 devel build 1 released, for XO-1.5 and XO-1

Peter Robinson pbrobinson at gmail.com
Mon Nov 7 13:14:54 EST 2011

On Mon, Nov 7, 2011 at 3:43 PM, Kevin Gordon <kgordon420 at gmail.com> wrote:
> On Mon, Nov 7, 2011 at 9:59 AM, Martin Langhoff <martin at laptop.org> wrote:
>> On Mon, Nov 7, 2011 at 9:41 AM, Peter Robinson <pbrobinson at gmail.com>
>> wrote:
>> > Yes, its coming to F17 as a feature, as I said previously, that
>> > doesn't mean that Fallback mode is going away in F17.
>> There's nothing in that discussion thread about keeping a knob to
>> enable fallback mode. The title of the thread says it all.
>> I was just going to send Ajax your build, I see you're one step ahead
>> of me :-) -- one thing is missing -- instructions on how to install
>> it, for someone who's gotten rusty (like Ajax who hasn't updated his
>> XOs in a while). And the XO-1 install process is different with UBIFS.
> I was fortunate enough to have DSD install an F17 build on an XO 1.5 when in
> SF.
> So, I'm up for anything you want me to test.  I downloaded the xo 1.5 files
> from build.laptop.org
> On a new XO 1.5, i just used the same proc  as previously for developer
> build installs:
> boot to OFW,  enter 'disable-security' to verify no wp tag so the install
> doesn't scrub mu ability to boot back into ofw :-)
> copy os1.zd4 onto a usb stick
> insert usb stick into XO 1.5
> fs-update u:\os1.zd4.


> The 'f'ile updated only 1 chunk' message is back, which means one enters
> 'reboot', but otherwise things were actually copied correctly.
> The firmware updated to Q3B22.
> It booted with a transient black screen, brings up the little arrow, then

Yes, no pretty boot just yet.

> goes to sugar arrow and boots into the sugar home screen, but has a little
> black square on the screen in the bottom left corner.

I have that on mine, we're at the beginning of the dev cycle to gtk3
so we might get weird bits here and there.

> Switched desktop to gnome.  Pretty b/g image, no desktop icons:-)

As expected.

> Wireless connected in gnome
> Switched back to sugar (using menu)
> Switched bac to sugar, little black square is gone.
> Wireless network persists on Sugar side :-)
> Shutdown from sugar doesnt immediately shutdown.  Goes to text mode, seems
> to go into a loop, then after about 2 minutes finishes the shutdown.
> Subsequent startup in sugar now does the unexpeceted  full black screen
> transition, and the little black square in the bottom left corner
> re-appears.
> Switch to gnome - being a fool, i cant find the shutdown icon, or an entry
> on a menu.  So, I go to terminal, enter shutdown, it broadcasts a 1 minute

Top right, click on the "olpc user" and you get the shutdown option.

> delay, message,  then shuts down.
> Reboot brings up prettyboot, then does the black screen transition again,
> and even on the gnome side, the little black square in the bottom left
> appears.

Thanks, it was about what I expected. We're about 3-4 months out from
the spit and polish side of things, more aimed at developers to get a
platform with systemd and all the libraries/tools needed for the port
to gtk3 etc.


> That's about all the time I have this morning to play.
> I'll try the XO-1 once I get home
> Cheers
> KG
> '
> I dont have an XO-1 with me, but I presume if it's ubifs, the files will
> also be the same (i.e. os1.onu and os1.uim), adn one will use the
> update-nand ofw command, instead of the jffs2 copy-nand command.  But, I'm
> presuming that.  Will let you know tonight.
> KG
>> > What is the state of merging out VIA driver back into mainline? That
>> > would certainly help from the XO 1.5 PoV.
>> That's for Jon to answer...
>> m
>> --
>>  martin at laptop.org -- Software Architect - OLPC
>>  - ask interesting questions
>>  - don't get distracted with shiny stuff  - working code first
>>  - http://wiki.laptop.org/go/User:Martinlanghoff
>> _______________________________________________
>> Devel mailing list
>> Devel at lists.laptop.org
>> http://lists.laptop.org/listinfo/devel

More information about the Devel mailing list