GCompris and xo-1

Leonardo Rojas lrojas at eduinnova.com
Mon Jan 31 08:24:59 EST 2011

First of all, sorry if my english its not very good since its not my native
languaje. I need to modify some GCompris activies and install them on a xo-1
Build number:852       Sugar: 0.84.16     Firmware : Q2E45
because the teachers dont like all the activities as they are, there are
some activities that are easy to modify because i can do the changes with
gcompris administration, like GCompris MissingLetter, but for the others i
need to recompile them.  I made changes on several, like MemoryEnumerate,
AlgebraGuesscount, Babymatch and others, then i run gcompris, and all the
changes are there, the activities work as intended but when i try to install
them on the xo, they dont start, i dont even get the

Cannot find cached 0sugar-launch implementation. or another error  (i know a
workaround for the 0sugar-launch imlmentation error, i get this error with
version 13 of activities mostly, all version 12 activities run perfect in
the xo

the icon appears then afther a while the activitie close, i tried using the
./bundleit.sh and  using setup.py, tried using GCompris 9.5 then Gcompris
9.3 (modifying the source files from the activities that come in that
GCompris version)
So my question is, someone knows how to compile and install a modified
GCompris activity in this xo?, really need help plz, im suposed to have them
installed and working on the xo next week.
sorry for the inconvenience
thx, bye
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20110131/d1e34be7/attachment.html>

More information about the Devel mailing list