Announcing Q2E42 firmware for XO-1.0

Yioryos Asprobounitis mavrothal at
Sat Feb 13 04:49:37 EST 2010

On a very fast test on XO-1 CL1. 
Running F11-XO1/os10 there are 2 batteries in frame.

However, the major problem appears to be that there is a delayed detection of the SDcard. Thus is looking for the olpc.fth file, first in USB then in the NAND and never in the SDcard. 
Booting from USB is fine.

Even flashing the firmware back to q2e41 with "flash sd:\boot\q2e41.rom", first time the response is "Cant't open device".  Re-type the command without rebooting. Is fine. 
Tried a  2 different SD cards just in case, one ext2 formated the other vfat. Same result.

Back to q2e41, everything is fine.


This release is for testing a number of security enhancements for XO-1.0 
and many other changes that have been added to the source tree during 
the development of XO-1.5. Since it has been a long time since the last 
XO-1.0 firmware release, it would not be surprising to find problems 
with this release, so the best guess is that another XO-1.0 release will 
be needed before widespread deployment.

    Changes since OLPC Firmware q2e41

    * Trac 9045 - key delegation
    * Trac 9362 - setup-smbios for Linux boots
    * Trac 9434 - nbclone to secure XO possible
    * Trac 9485 - Secure Windows boot
    * Trac 9972 and others - Fixed numerous problems with ext2
      filesystem package
    * Numerous improvements to USB stack
    * Improvements to SDHCI driver
    * Many other changes in support of XO-1.5, some of which had
      (hopefully minor) impact on XO-1.0 code


More information about the Devel mailing list