Record activity performance

Sridhar Dhanapalan sridhar at
Thu Dec 23 18:36:56 EST 2010

On 23 December 2010 17:10, James Cameron <quozl at> wrote:
> On Thu, Dec 23, 2010 at 04:53:26PM +1100, Sridhar Dhanapalan wrote:
>> Firstly, I tried Record after having used the XO with various
>> activities (Musicpainter, Image Thumbnail, etc.) and closed them
>> (leaving nothing else running). Recording in Low for 2 min appeared to
>> work, but playback gave no sound, and it paused after about 10
>> seconds.
> That's interesting.  I've not heard about that.  What version of those
> activities?  Where do you get Musicpainter from?  I can't see it at
>  Nor can I see anything called Thumbnail.
> If these activities change the mixer controls at all then this may lead
> to the "no sound" symptom you describe.

Musicpainter and Image Thumbnail are new activities created by us,
which we haven't yet fully released (I haven't submitted them to ASLO
yet). I'm now suspecting that the Musicpainter is the culprit, so
that's our problem to investigate.

The project pages for those activities are:

>> Restarting the XO, I ran Record again. Playback of the video was fine.
>> Then I recorded a 2 min video in High quality. Fast movement, etc.
>> seemed okay until the final ~30 seconds. At this point, the screen
>> updated very slowly. I reduced the image complexity so that it was
>> able to catch up by the end.
>> Playing back the High quality video gave me what I had seen on the
>> screen when recording, i.e. it was fine until about 30 secs remaining.
>> Then the frame rate slowed to a crawl. Audio continued to be smooth
>> despite the video. The video was fine by the final few seconds, in
>> sync with the audio.
>> We're tracking this here:
>> Does anyone have any ideas on what can be done to address this?
> Everything else you said above, apart from the "no sound" symptom,
> matches what we placed in the release notes for 10.1.2.

Reading that again, yes it does match. I didn't think the scene was
very complex, but I think the last sentence adequately explains the
behaviour: "In this release the frame rate is kept as fast as possible
until the pause is unavoidable."

> What class SD card are you using?

Class 2. I've been informed that Quanta do not offer anything faster,
as none meet durability requirements.

> Since the version of Record has not changed between 10.1.2 and 10.1.3,
> it is expected that the same problem will affect 10.1.3.
> It sounds like "High quality" may need removing temporarily if this
> problem isn't fixed.

I was thinking that. Unfortunately this bug makes Record look 'broken'
to a lot of people, and it doesn't create a good perception of the

I was thinking of releasing our own version with High disabled in (just as Best is), but thought it better to discuss here first.


More information about the Devel mailing list