USB Ethernet test

Kevin Gordon kgordon420 at
Sat Dec 18 16:06:49 EST 2010


Just writing to let you know that I'm still working on the test case :<>

I've set up two Windows machines each with a USB/Ethernet connector and a
crossover cable and disabled all networking interfaces except the USB.  They
behave as expected : after a few seconds assigning the Windows APIPA 169
series addresses and communicate with each other using unique addresses.
So, I now have verified that the hardware is solid.  The USB adapters are
the ZoWii's that were in the swag bag at the SFSU summit.  Model ZU-80
Zoltantech is what they say on the outside, but they identify themselves n
device manager as ASIX AX88772.  Their USB id is 0b95:7720.

I have also done this hardware test by hooking the usb adapters to ports on
a switch with no DHCP server, and here too the hardware functions as

The reason I'm running behind is that I tried to downgrade my two F14/OS4
machines back to 802 to add to the test environment and ran in to problems
reinstalling 802 with our customization version, using the old /bundles
/boot/ type signed build method.  It didn't seem to want to reboot
and run the bundle install portion.  However, it was determined that it was
only not working on the XO's that had security permanently disabled.  That
took me a bit of time to figure out.  Then, after the unsuccessful attempt
to install 802, the x-key boot to OFW also no longer worked - i was at a bit
of an impasse.  So, I installed a full stable 852  with activities, , now
had sugar and re-installed the developer key.  I then I could reboot into

Alas, even though I brilliantly guessed the command, :-) I had to go find
the actual format of the enable-security command so as not to get the
unexpected end-of-line error. With the Serial number so conveniently
appearing on the top of the OFW boot screen, security was renabled and I now
have 2 XO 802's with full bundles using the above mentioned USB stick
install.   I  now finally have the 6 XO's set up for the next phase.  2 at
802, 2 at 852, and 2 at 359.  I also have one XO 1.5 at 852 and another one
at 359 to test.  I'll also be introducing a vanilla IBM Thinkpad with F11,
fully updated,  to see how it behaves when following James' zeroconf/avahi
test plan.

So far, I can really only verify the initial successful base behaviour which
gave rise to the discussion:  that the USB adaptors work on the XO1 at 802,
wherin a 169 address is successfully assigned automatically when an 802 XO1
is cross-over connected to a Windows machine via, or when connected to the

So, bottom line: the rookie is a little behind in his work, but I am
plodding along.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list