Kevin Gordon kgordon420 at
Wed Dec 15 09:52:28 EST 2010


A bit more info.  This echo response issue is only happening in my
environment when the external monitor is plugged in, and happens on either
test monitor, and using either Startech.

For the test, I'm just typing 123123123 repeatedly into terminal.  This
symptom happens both on gnome and sugar terminal screens.

It's a 'production' XO-1 with the three pad trackpad..  It is a virgin
fs-update install of build 358

However, I have now ascertained that It is not actually a  'delay' it's a
full pause.  Meaning, when it stops echoing it *stops*;  then, only when I
hit the next character, do both the previous and the current characters
echo.  To be clear, if I type 123, and only the 1 and 2 appear,  then when I
hit 1, both the 3 and the 1 then appear.

I will try the tackpad wiggle, and also try the whole test again this
time on the XO 1.5 later today.

Unfortunately,  for now, Work interferes again :-)

On Tue, Dec 14, 2010 at 4:29 PM, James Cameron <quozl at> wrote:

> On Tue, Dec 14, 2010 at 07:53:53AM -0500, Kevin Gordon wrote:
> > One other thing I need to check further is that the XO 1.0 seems to
> > have a sluggish keyboard echo response to the screen when plugged into
> > the external monitor. sometimes when I'm tapping a sentence it pauses
> > for up to 2 seconds before echoing back the text.  I need to check
> > more closely that it is purely ext monitor related, I think.
> A similar symptom was seen in the past day on an XO-1 with single-area
> Synaptics touchpad running an upstream kernel.  Key events were delayed
> by the interrupt stream from the touchpad.  It has not been seen on the
> OLPC kernel yet.  If it occurs with power management disabled, you can
> exclude idle suspend as a contributing cause.
> --
> James Cameron
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list