Problem creating .xo bundle

Art Hunkins abhunkin at
Tue Jun 23 15:21:56 EDT 2009

Very interesting; I get a response!

I tried python dist_xo, and that created the .xo distribution for 
me as well - and without executable permission too.

I don't find anywhere in the various docs (especially the Activity Tutorial) 
where you need "python" in front of "" on the OLPC! Did I miss 

Thanks for getting me on the right track.

I think I can assume then that "x" permission is not required for any of the 
.py scripts included in an .xo bundle - is that correct? (I don't see any in 
the other bundles I've examined.)

Art Hunkins

----- Original Message ----- 
From: "Walter Bender" <walter.bender at>
To: "Art Hunkins" <abhunkin at>
Sent: Tuesday, June 23, 2009 12:30 PM
Subject: Re: Problem creating .xo bundle

what happens when you run:




On Tue, Jun 23, 2009 at 12:28 PM, Art Hunkins<abhunkin at> wrote:
> Thanks for the reply, Gary (Aaron as well!)
> Yes, execute permissions are set correctly for
> My file reads exactly the same as yours.
> I'm still getting the same problemmatic results as below.
> I'm developing largely on the XO itself, with help from my Windows (XP)
> computer and some thumb drives. I'm using the XO's builtin nano editor.
> My XO build is 802, with Q2E41 firmware. As I recall, I'm working with a
> developer key, FWIW.
> Any further ideas?
> Art Hunkins
> ----- Original Message ----- From: "Gary C Martin" <gary at>
> To: "Art Hunkins" <abhunkin at>
> Cc: <devel at>; <walter.bender at>
> Sent: Monday, June 22, 2009 11:05 PM
> Subject: Re: Problem creating .xo bundle
>> Hi Art,
>> On 23 Jun 2009, at 03:40, Art Hunkins wrote:
>>> I've got an XO Activity ready to go, and working perfectly in my (XO)
>>> Activities folder. (It's called OurMusic.activity.)
>>> I just can't seem to make an .xo bundle of it.
>>> From my activity's folder (OurMusic.activity) I run:
>>> ./ dist_xo
>>> and get:
>>> : No such file or directory
>>> If I run:
>>> dist_xo
>>> or just
>>> I get:
>>> bash: command not found
>>> (and is right there in the folder, with correct permissions.)
>> Hmmm, so does have execute permissions (chmod +x
>>> Can someone give me guidance, please? (Happy to send along my,
>>> MANIFEST and files if relevent.)
>> My's just look like this:
>> #!/usr/bin/env python
>> from sugar.activity import bundlebuilder
>> bundlebuilder.start()
>> Running ./ on its own should just give you its usage 
>> instructions.
>> What environment are you developing under? Might give us some more clues
>> :-)
>> Regards,
>> --Gary
>> P.S. You might want to join the sugar-devel mail-list
>> ( ), that's where most of 
>> the
>> current folks working on Sugar/Activities are.

Walter Bender
Sugar Labs 

More information about the Devel mailing list