Problem creating .xo bundle

Bert Freudenberg bert at
Tue Jun 23 06:21:54 EDT 2009

On 23.06.2009, at 04:40, Art Hunkins wrote:

> I've got an XO Activity ready to go, and working perfectly in my (XO)
> Activities folder. (It's called OurMusic.activity.)
> I just can't seem to make an .xo bundle of it.
> From my activity's folder (OurMusic.activity) I run:
> ./ dist_xo
> and get:
> : No such file or directory
> If I run:
> dist_xo
> or just
> I get:
> bash: command not found
> (and is right there in the folder, with correct permissions.)
> Can someone give me guidance, please? (Happy to send along my  
> MANIFEST and files if relevent.) is not needed:

cd ~/Activities
zip -r OurMusic.activity
mv OurMusic-1.xo simply ensures that you use the right version number for the  
bundle file name, it includes only what's listed in MANIFEST, it uses  
the right directory etc. But if you know all these constraints you can  
simply use zip to make a bundle. No magic involved :)

- Bert -

More information about the Devel mailing list