setup for XO development

Paolo j.s.sebastian at
Thu Oct 30 09:55:00 EDT 2008


I would like to try out the XO software and get started with doing some

As I am a security guy, I am mostly interested in core development,
especially bitfrost/rainbow, and the document store. I expect an
emulated environment would be a good choice for this type of development.

I followed instructions on the wiki and tried to set up virtualbox 
(because it's what I already use, I have no problems switching to
kvm/qemu if needed, although unfortunately the 2 will not run side by
side on the same system).

The image I am using is the official build 767:
on an amd64 ubuntu hardy, with latest non-free virtualbox (2.0.4).
..but I ran into the 3dnow problem that other people have complained
about already. When booting, I get the following message:

This kernel requires the following features not present on the CPU:
Unable to boot - please use a kernel appropriate for your CPU.

Should I try kvm/qemu to solve this problem? Or are there other olpc
images I should be using?

Or should I try running it natively? I would rather not have to dual-boot...

Or, finally, should I rebuild myself an image from scratch, with a
non-3dnow kernel?

I'm not afraid to try any of these options but I'd rather not have to
try them all before I get anything working, which is why I am asking for
help  ;-) 

Paolo Milani

More information about the Devel mailing list