Upgrade G1G1 using autoreinstallation method

Pia Waugh greebo at pipka.org
Wed Jun 18 02:35:27 EDT 2008

Hi all,

<quote who="John Watlington">

> I'm glad you found a solution.   Can you provide more information (such as
> exactly what model of AP are you using ?  Which versions of firmware
> worked/didn't work.)

Just wanted to give everyone an update. I bought a DLink DWL-2100AP which is
what David and Ian are trying to implement for their XO rollouts. We found
that we could not get DHCP working on the AP at all for either an XO or for
an IBM laptop running Ubuntu. We tried several different firmware versions
(although the AP is seemingly locked to European firmware and we can't use
the US ones) and the only way we could use it was as an AP that forwards
DHCP requests to the network.

We've spent about 4 hours today trying to troubleshoot the issues and I am
unfortunately going to have to recommend that the APs be plugged into a
network which plugs into an XS server for DHCP to get the XOs connected.
David, where you can't have an XS server you could always buy a different AP
or other DHCP allocation device per site for DHCP resolution as these APs
seem to be inappropriate for the job (at least the Australian ones).


OLPC Australia                                           http://olpc.org.au/
Linux Australia                                         http://linux.org.au/
Open Source Industry Australia                           http://osia.net.au/
Software Freedom Day                          http://softwarefreedomday.org/
                 "I dig your vibe." - Rove McManus to Ice T

More information about the Devel mailing list