newbie question - need to get libstdc++.so.5

Dan Williams dcbw at redhat.com
Mon Jan 8 15:26:30 EST 2007


On Mon, 2007-01-08 at 15:10 -0500, Geir Magnusson Jr. wrote:
> Hi,
> 
> I'm a newbie so forgive the stupid questions and misnaming things -  
> I'll learn quickly...
> 
> I'm playing around with getting Apache Harmony (an OSS impl of Java  
> SE) to run on an OLPC image running in Parallels in OS X.  Currently,  
> I'm using build 218.

Does harmony _require_ libstdc++.so.5?  Since it's OSS, you probably
want to either yell at them build against a gcc >= 4, or rebuild it
yourself against libstdc++.so.6.  For playing around with, I can
understand installing .5.  But you should really make it use .6 at a
later date.

Until then:

yum install compat-libstdc++-33

Dan

> Can someone tell me the right way to get libstdc++.so.5 installed?  I  
> assume I use rpm? (I've been spending most of my time in ubuntu-land  
> lately, so I'm rusty...)
> 
> How am I sure I get the right build?
> 
> thanks in advance, and again, sorry for the newbie question - my  
> questions will get smarter over time :)
> 
> geir
> 
> _______________________________________________
> Devel mailing list
> Devel at laptop.org
> http://mailman.laptop.org/mailman/listinfo/devel



More information about the Devel mailing list