[Testing] Testing Summary: 3 September 2011 - Auckland, New Zealand

Tabitha Roder tabitha at tabitha.net.nz
Sat Sep 3 03:02:09 EDT 2011

Testing Summary: 3 September 2011 - Auckland, New Zealand

Testing os3 on XO-1.0s and XO-1.5s. Couldn't see any new build for XO-1.75
so no tests on these.

XO-1.5s running os3 - used Ivy and Poppy-Copy - no collaboration tested as
Poppy wireless broken
Turned off automatic power management

Record - photo, video, audio all successful, change photo quality successful

Implode - works

Maze 11 - fails to start on both XO-1.5s. Logs are empty. cjl says dirakx
patched -
http://lists.sugarlabs.org/archive/sugar-devel/2011-September/033133.html -
so this might need reviewing. There is a newer Maze (12) but that is not in
this build, installed this version and it works.

Memorize - can play all existing games and can create and play a new one.

Measure - works

Physics - works

Browse 123 - fails to start. Logs show problems. Likely same as

> ** Message: pygobject_register_sinkfunc is deprecated (HippoCanvasBox)
> Registering '@mozilla.org/module-loader/python;1' (libpyloader.so)
> Registering 'Python.TestComponent' (py_test_component.py)
> Registering '@mozilla.org/network/protocol/about;1?what=python'
> (pyabout.py)
> returning
> /home/olpc/.sugar/default/org.laptop.WebActivity/data/gecko/prefs.js for key
> Traceback (most recent call last):
>   File "/usr/bin/sugar-activity", line 21, in <module>
>     main.main()
>   File "/usr/lib/python2.7/site-packages/sugar/activity/main.py", line 121,
> in main
>     module = __import__(module_name)
>   File "/home/olpc/Activities/Browse.activity/webactivity.py", line 176, in
> <module>
>     from webtoolbar import PrimaryToolbar
>   File "/home/olpc/Activities/Browse.activity/webtoolbar.py", line 29, in
> <module>
>     from sugar._sugarext import AddressEntry
> ImportError: cannot import name AddressEntry
> Exited with status 1, pid 2367 data (None, <open file '<fdopen>', mode 'w'
> at 0xabd38b8>, '57826ffab80eef40b8e9971546fa6e125c166e93')
 Browse 125 from aslo works

Calculator - sin, cosine and tangent are expecting integers, if you enter a
decimal it gives error message:

> Error at 1: unsupported operand time (s) for *:'Decimal' and 'float'
Tried this on the Android phone calculator and it is possible to use

Stopwatch - works

Terminal - works

Logs - icon doesnt change colour once you have used this activity.

Speak - works, robot too

Journal - have a documents option in the bottom of the screen next to the

Tamtam Mini - works

FotoToon - works

Clock - works

Moon - works

Ruler - works

Paint - works, tried a few different functions

Write - works, tried a few different functions

Labyrinth - basic test successful

Scratch - works


XO-1.0 running os3 - used Shrek and Tux
Flashed Shrek with os3 and it says "can't mount root filesystem, boot has
failed, sleeping forever". Reimaged and fixed.
Tux worked.
Maze - fails to start.
Browse - fails to start.
Memorize works
Implode works
Chat works between 2 XO-1.0s
Write works between 2 XO-1.0s
Record works between 2 XO-1.0s
Abacus works (just tried one)
Turtleart works
Paint works

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/testing/attachments/20110903/20bb3e52/attachment.html>

More information about the Testing mailing list