[Testing] Testing Summary: 1 October 2011 - Auckland, New Zealand

Gary Martin garycmartin at googlemail.com
Sat Oct 1 14:42:20 EDT 2011

Hi Tabitha,

Thanks for all the feedback!

On 1 Oct 2011, at 08:16, Tabitha Roder wrote:

> Who: Fabiana, Oliver, Rachel, Tabitha, Tom, (and random kids and adults in the bar)
> Testing Sugar 0.93.5 build 7 customised on XO-1.0 and XO-1.5 and XO-1.75
> Discovered that Maze resume from Journal takes you back to level 1.

Here's the existing ticket (I've added a comment pointing back here):


> Copy from USB to Journal - when you drag an item from the USB to the Journal you get the whole bar being dragged, not just the icon of the item

I'm sure we had a ticket open for this already, but I could not find it so have opened a new one here:


> WikipediaEN 28 goes to the browse home page when you click home instead of the Wikipedia homepage
> Spent quite a lot of time with Memorize talking to Gary & friends on irc about interactions with the journal. Ran quite a lot of collaborative games with no problems (AP wifi with internet access). Still working on: best names for the buttons;

Yep, but think we're close (certainly the strings are improved vs. old Memorize) :)

> best ways to create new games and save them, edit those games and create completely new games.

So, to try and cut to the chase on this one (please correct me if I misunderstood) – Tabitha and team find the current Sugar workflow for starting and stopping new activities too burdensome in a typical class situation:

1) select 'Start new' activity from sugar home view
2) use activity
3) click 'Stop' button in activity toolbar
... repeat

This is the burden in all sugar activities, but in the case of Memorize the old UI used the regular OS metaphor of loading, naming and saving each game individually to and from the Journal. Memorize actually had no Journal state of its own, it just saved and loaded separate entries, if you didn't manually save you lost your work.

The new version of Memorize stores the game state automatically to its Journal entry (e.g. when you 'Stop', switch views, or you shut your machine down) like most activities – so you now need to use the above 1, 2, 3 steps to create new works (new journal entries).

It's worth mentioning that Sugar 0.93 includes a new 'Duplicate' feature that offers another possible workflow if you don't want to 'Stop' an activity. While using any activity:

1) switch to Journal 
2) right click your current entry and select 'Duplicate'
3) switch back to activity

You now have preserved a duplicate of your activity state, and can carry on using your existing activity.

There are a couple of feature proposals coming down the line that should also help improve the workflow for all activities:

- A 'Detail' view that can be raised at any time by an activity, the 'Detail' view contains a 'Duplicate' button so you can avoid switching to your journal and back again to make a duplicate.

- The Home view will not 'Resume' or 'Start new' by default (we have tried both extremes and there are issue with each). On selecting an Activity we'll present the options to 'Start new' or 'Resume'. It means the user has to make two clicks/touches from the Home view to get into an activity, but it is at least an explicit user choice to create something new, or continue with some past work.

Well be looking closely for testing feedback on these changes, not sure when we'll have patches available to test but will keep you in the loop.

> Browse worked well on all hardware.
> On XO-1.75:
> os7 is much faster than os6, restoring the performance we saw with os42.
> Quite a lot of activities die on XO-1.75 with an "Insufficient Resources" error inside the X server, see http://dev.laptop.org/ticket/11295 for reliable steps to reproduce with the Wikipedia activity. Sometimes the whole X Server crashes (or at least it restarts) with no clear cause. We did not see this behavior on XO-1.5 and XO-1.
> EToys got stuck in an infinite loop writing:
> snd_pcm_writei returned -11
> to it's log. It consumed 100% cpu and wrote 48MB of log before we worked out what was wrong. Log was unable to view this log but didn't log any errors in it's log.
> Our wifi has a password and on one XO-1.75 it ended up next to the central XO in the neighbourhood. After dismissing the password window which covered the XO, the XO was not re-drawn correctly, see https://picasaweb.google.com/lh/photo/TgXbMYBLG_mKrkCwyr7UTA?feat=directlink

Sounds like a case of the gfx driver redraw issue on the XO-1.75

> I was not able to recreate this situation to see if it is consistent (how do you forget a wifi password or move a network icon?).

You can't move a network icon. You can forget _all_ wifi passwords using 'My Settings' --> 'Network' --> 'Discard network history'. There is a future sugar feature proposal (and some patches I think), that add an extra option to each access point palette that allow you to forget just one specific set of remembered credentials (e.g. if you accidentally log into the wrong AP you can forget it's details so Sugar does not automatically try to reconnect to it).

> I saw several times inconsistencies between program icons in the frame and the actual running programs. https://picasaweb.google.com/lh/photo/pgM5QSaVKcugTz-DUb965Q?feat=directlink shows two Memorize icons, but only one is actually running and the left one is skipped when using alt tab. I aslo saw a similarly unused (possibly pulsing) browse icon to the right of a grey circle icon which actually got highlighted when browse had the focus.
> On XO-1.75 the Maze is enormous and doesn't fit on the screen: https://picasaweb.google.com/lh/photo/IPTNSuityizo2d9E8ZRaqA?feat=directlink Maze is normal sized on the XO-1.0

Pretty sure this has been fixed now (both in activity and in an X tweak to the next build).

> The floor in Physics on XO-1.75 is about 1/3 of the screen height below the bottom of the screen, so objects have to be quite large to be partially visible when resting on the floor. (sorry no screenshot and we didn't try on other hardware).

This is also fixed, in git, I'll release a new version soon (trying to land a few other bug fixes if I can).


> alt-f1 screenshot doesn't seem to work so I had to take photos with a phone.
> Thanks 
> NZ testers
> _______________________________________________
> Testing mailing list
> Testing at lists.laptop.org
> http://lists.laptop.org/listinfo/testing

More information about the Testing mailing list