[Testing] Testing Summary: 1 October 2011 - Auckland, New Zealand

Tabitha Roder tabitha at tabitha.net.nz
Sat Oct 1 03:16:13 EDT 2011

Who: Fabiana, Oliver, Rachel, Tabitha, Tom, (and random kids and adults in
the bar)

Testing Sugar 0.93.5 build 7 customised on XO-1.0 and XO-1.5 and XO-1.75

Discovered that Maze resume from Journal takes you back to level 1.

Copy from USB to Journal - when you drag an item from the USB to the Journal
you get the whole bar being dragged, not just the icon of the item

WikipediaEN 28 goes to the browse home page when you click home instead of
the Wikipedia homepage

Spent quite a lot of time with Memorize talking to Gary & friends on irc
about interactions with the journal. Ran quite a lot of collaborative games
with no problems (AP wifi with internet access). Still working on: best
names for the buttons; best ways to create new games and save them, edit
those games and create completely new games.

Browse worked well on all hardware.

On XO-1.75:
os7 is much faster than os6, restoring the performance we saw with os42.

Quite a lot of activities die on XO-1.75 with an "Insufficient Resources"
error inside the X server, see http://dev.laptop.org/ticket/11295 for
reliable steps to reproduce with the Wikipedia activity. Sometimes the whole
X Server crashes (or at least it restarts) with no clear cause. We did not
see this behavior on XO-1.5 and XO-1.

EToys got stuck in an infinite loop writing:

snd_pcm_writei returned -11

to it's log. It consumed 100% cpu and wrote 48MB of log before we worked out
what was wrong. Log was unable to view this log but didn't log any errors in
it's log.

Our wifi has a password and on one XO-1.75 it ended up next to the central
XO in the neighbourhood. After dismissing the password window which covered
the XO, the XO was not re-drawn correctly, see
was not able to recreate this situation to see if it is consistent
(how do
you forget a wifi password or move a network icon?).

I saw several times inconsistencies between program icons in the frame and
the actual running programs.
two Memorize icons, but only one is actually running and the left one
is skipped when using alt tab. I aslo saw a similarly unused (possibly
pulsing) browse icon to the right of a grey circle icon which actually got
highlighted when browse had the focus.

On XO-1.75 the Maze is enormous and doesn't fit on the screen:
is normal sized on the XO-1.0

The floor in Physics on XO-1.75 is about 1/3 of the screen height below the
bottom of the screen, so objects have to be quite large to be partially
visible when resting on the floor. (sorry no screenshot and we didn't try on
other hardware).

alt-f1 screenshot doesn't seem to work so I had to take photos with a phone.

NZ testers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/testing/attachments/20111001/04fc8005/attachment.html>

More information about the Testing mailing list