[Testing] Testing summary: 23 July 2011 - Auckland, NZ

Tabitha Roder tabitha at tabitha.net.nz
Sat Jul 23 06:51:10 EDT 2011

Testing summary: 23 July 2011 - Auckland, NZ
Who: Fabiana, Nevyn, Oliver, Tabitha, Tom

os874 on XO-1 and XO-1.5 with schoolserver on private wifi network with no
internet access.

Registering with the schoolserver didn't work first time for some of our
laptops. Trying again succeeded. I see timeout errors in the shell.log on
ivy (attached).

Tested collaboration in Write. All contributors writing is appearing in the
same colour. Could add image from record but you have to get the image from
the table menu which is weird.

Other laptops in the neighbourhood are named with what looks like some kind
of UUID at schoolserver. This doesn't seem to be deterministic, on anna, every
other laptop has ids of this form, on ivy all other laptops except tux have
a name of this form (tux is named tux as expected). See

On moodle, we see all the other laptops have the uuid name, except anna
which has a normal name. However anna shows up twice in the neighbourhood.
Anna and moodle and a bunch of other laptops are in a chat which is working

Names appear correctly inside chat.

Maze doesn't seem to share, we get many crashes and strangeness -- usually
maze would start and then shortly afterwards freeze up and disappear. See
attached for logs. Maze works without sharing using the three options
(gaming keys each side of screen and the arrow keys on keyboard).

Fabiana finally beat implode on hard level and declares that this activity
must have been fixed. ;-p

Memorize 3 players success with all preloaded games and one user generated
word game.

Speak worked, robot did respond to the questions we asked.

Shared record; pictures do appear on other XOs sharing the activity.

Measure worked.

Sending files between XOs worked, but the file send and receive icons never
disappeared from the frame.

While we didn't encounter any problems collaborating (except for the maze
and neighbourhood problems), we did see a lot of errors in shell.log and
chat.log, see attached.

http://bugs.sugarlabs.org/ticket/2793 is fixed in Read 90, to the point you
can't use the arrow keys while changing the activity name (they move the
document in the main window, not the cursor in the name box).

We went to Tangleball (a local makerspace) after testing and showed off the
XOs at their open day. One person suggested physics should have controllable
gravity. This is in a similar vein to suggestions for specifying different
density of objects to explore small and heavy compared with big and light.

Thanks testers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/testing/attachments/20110723/f36c3e0e/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: logs.tar.bz2
Type: application/x-bzip2
Size: 15366 bytes
Desc: not available
URL: <http://lists.laptop.org/pipermail/testing/attachments/20110723/f36c3e0e/attachment-0001.bin>

More information about the Testing mailing list