[Server-devel] [XSCE] ansible install on a 1.75 with low RAM

Tim Moody tim at timmoody.com
Fri Jun 6 14:28:09 EDT 2014

I had a similar issue with a VBox VM that only had 768M memory.  The errors 
I saw looked like download timeouts at squid, ajenti, etc. which I put down 
to poor internet connectivity as I was travelling.  I upped memory to 1G, 
but still had the same problems.

However, I just tried it again at home where I have a fast connection and it 
still failed on the ajenti step.  So I tried your suggestion with 
tags="ajenti", which failed the first time but succeeded the second.

The error below still looks like network timeout.  The reason this is 
important is that we have discussed raising the priority of offline install 
based on my assumption that connectivity was the issue, but this will 
probably not help if the problem is insufficient RAM.

/bin/pip run on Fri Jun  6 13:49:52 2014

  Downloading from URL 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pip/basecommand.py", line 139, in 
    status = self.run(options, args)
  File "/usr/lib/python2.7/site-packages/pip/commands/install.py", line 266, 
in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, 
  File "/usr/lib/python2.7/site-packages/pip/req.py", line 1033, in 
    self.unpack_url(url, location, self.is_download)
  File "/usr/lib/python2.7/site-packages/pip/req.py", line 1161, in 
    retval = unpack_http_url(link, location, self.download_cache, 
  File "/usr/lib/python2.7/site-packages/pip/download.py", line 554, in 
    download_hash = _download_url(resp, link, temp_location)
  File "/usr/lib/python2.7/site-packages/pip/download.py", line 458, in 
    chunk = resp.read(4096)
  File "/usr/lib/python2.7/socket.py", line 380, in read
    data = self._sock.recv(left)
  File "/usr/lib/python2.7/httplib.py", line 561, in read
    s = self.fp.read(amt)
  File "/usr/lib/python2.7/socket.py", line 380, in read
    data = self._sock.recv(left)
  File "/usr/lib/python2.7/ssl.py", line 241, in recv
    return self.read(buflen)
  File "/usr/lib/python2.7/ssl.py", line 160, in read
    return self._sslobj.read(len)
SSLError: The read operation timed out

-----Original Message----- 
From: Sameer Verma
Sent: Thursday, June 05, 2014 10:23 PM
To: XS Devel ; xsce-devel
Subject: [XSCE] ansible install on a 1.75 with low RAM

I've been helping Anish with some server testing. I have a XO 1.75
with 512MB RAM. After installing the 13.2 build, and following
instructions from

./runansible fails repeatedly, and at varying successive points. I
suspect this is due to a low amount of RAM and no swap (I see memory
page errors at the console). After running ./runansible a few times, I
decided to install using one playbook at a time. The initial runs had
failed at squid, so I started there.

ansible-playbook -i ansible_hosts xsce.yml --connection=local --tags="squid"

Installing services like this, with one playbook at a time works.
After all the playbooks, I ran ./runansible again and it ran through

Putting this out there in case someone else gets stuck.

Sameer Verma, Ph.D.
Professor, Information Systems
San Francisco State University

More information about the Server-devel mailing list