[Server-devel] [support-gang] Attempting to upgrade XO 1.5 firmware. Says "activation lease not found"

James Cameron quozl at laptop.org
Wed Jul 31 19:08:53 EDT 2013

If it is reaching "Can't open network" then it has failed to read or
verify the files you put on the USB drive.  If the lines above that
match exactly what Kevin reported on 19th July then the files could
not be read from the USB drive.

Things you should try:

- another USB drive,

- another USB port on the laptop,

- check the size and checksum of the files,

The size of 32013o1.zd should be 833068483 bytes.

The size of fs1.zip should be 1314218 bytes.

The checksum of 32013o1.zd should be

The checksum of fs1.zip should be

If there is anything different about the lines before "Can't open
network", then please describe them.

On Wed, Jul 31, 2013 at 06:55:53PM -0400, Becky Young wrote:
> I am getting this exact message on an XO 1.5.  I updated the firmware.  I
> followed the directions for updating firmware on a secure laptop.  Now it says
> Q3C15.  I am using the files 32013o1.zd and fs1.zip.  I hold down the gamekeys
> and then I get Can't open network again.  Any ideas?  I am sorry for the
> urgency, but I am leaving Honduras tomorrow.  If anyone can respond quickly, it
> would be very helpful.
> Becky
> On Fri, Jul 19, 2013 at 10:58 AM, Kevin Cole <dc.loco at gmail.com> wrote:
>     Unfixable bug: I'm an idiot, sometimes.
>     I don't know if it's typical, but I often find that the USB port on
>     the left side of the screen doesn't seem to work as nicely as the ones
>     on the right.  A fact that I forget, because I so rarely use the USB
>     ports. As per Mr. Drake's request, the exact messages I saw before
>     failure were (unless I made another stupid typo copying):
>        Trying disk:\fs.zip
>        Trying disk:\fs1.zip
>        Trying ext:\fs.zip
>        Trying ext:\fs1.zip
>        Trying NANDblaster
>        Boot device /dropin-fs:nb15_rx Arguments: ssid:OLPC-NANDblaster
>        Scan for: OLPC-NANDblaster not found
>        Can't open network
>        ok
>     which I hadn't tried to interpret the first time. I noticed
>     "NANDblaster" and remembered reading something about the firmware
>     fixing NANDblaster, and went on a wild goose chase the first time
>     around.
>     This time less, rushed than yesterday, and armed with suggestions from
>     the list, I tried the same USB thumb drive on the one of the USB ports
>     on the right, and voila: away it went on its reflashing.
>     Next up, the XSCE, which looks pretty straightforward, given that I've
>     done stuff with RPMs for many years.
>     So, apologies and thanks to all.
>     _______________________________________________
>     support-gang mailing list
>     support-gang at lists.laptop.org
>     http://lists.laptop.org/listinfo/support-gang

> _______________________________________________
> support-gang mailing list
> support-gang at lists.laptop.org
> http://lists.laptop.org/listinfo/support-gang

James Cameron

More information about the Server-devel mailing list