[Server-devel] Attempting to upgrade XO 1.5 firmware. Says "activation lease not found"

Kevin Cole dc.loco at gmail.com
Fri Jul 19 10:58:45 EDT 2013

Unfixable bug: I'm an idiot, sometimes.

I don't know if it's typical, but I often find that the USB port on
the left side of the screen doesn't seem to work as nicely as the ones
on the right.  A fact that I forget, because I so rarely use the USB
ports. As per Mr. Drake's request, the exact messages I saw before
failure were (unless I made another stupid typo copying):

   Trying disk:\fs.zip
   Trying disk:\fs1.zip
   Trying ext:\fs.zip
   Trying ext:\fs1.zip
   Trying NANDblaster
   Boot device /dropin-fs:nb15_rx Arguments: ssid:OLPC-NANDblaster
   Scan for: OLPC-NANDblaster not found
   Can't open network

which I hadn't tried to interpret the first time. I noticed
"NANDblaster" and remembered reading something about the firmware
fixing NANDblaster, and went on a wild goose chase the first time

This time less, rushed than yesterday, and armed with suggestions from
the list, I tried the same USB thumb drive on the one of the USB ports
on the right, and voila: away it went on its reflashing.

Next up, the XSCE, which looks pretty straightforward, given that I've
done stuff with RPMs for many years.

So, apologies and thanks to all.

More information about the Server-devel mailing list