[Server-devel] Error Installing XS 0.7 from USB: can't find image #1 on disk

Jerry Vonau jvonau at shaw.ca
Sat Jul 28 01:12:46 EDT 2012

On Fri, 2012-07-27 at 21:51 -0700, Brian wrote:
> On Jul 27, 2012, at 9:04 PM, Jerry Vonau <jvonau at shaw.ca> wrote:
> > 
> > Using the windows tool is not recommended, use mkusbinstall[1] from the
> > XS-repo, and you would need livecd-tools from Fedora 16 or greater
> > installed. Which version of the windows tool are are you using? Maybe we
> > can work with what was created, can you show me the layout that was
> > created on the  
> I don't have another Linux box available here to run mkusbinstall. I tried unetbootin but it wouldnt make it bootable so tried another app called Rufus iirc which is like DD for windows to move the ISO to USB. 
> I booted into rescue mode and mounted /dev/sdb1 and here are the contents of /:
> Packages/
> autorun.ico
> Autorun.inf
> images/
> isolinux/
> ldlinux.sys
> media.repo
> olpcxs.ks
> repodata/
> syslinux.cfg
> In images/ are install.img, updates.img. 
> Brian

Based on the updates.img[1] think the installer is looking for the iso
image of the cdrom, can you try copying the whole XS iso image to the
root of the usbdrive, rename repodata, packages, and media.repo.
Try that first, if that fails you might have to revert the changes to
isolinux.cfg and try again.



More information about the Server-devel mailing list