[Server-devel] fresh 0.6 install

Tim Moody timmoody at sympatico.ca
Fri Oct 2 09:39:14 EDT 2009

> Message: 2
> Date: Thu, 01 Oct 2009 14:27:16 -0500
> From: Jerry Vonau <jvonau at shaw.ca>
> Subject: Re: [Server-devel] fresh 0.6 install
> To: Tim Moody <timmoody at sympatico.ca>
> Cc: server-devel at lists.laptop.org
> Message-ID: <1254425236.22407.83.camel at f9.vonau.ca>
> Content-Type: text/plain
> On Thu, 2009-10-01 at 14:15 -0400, Tim Moody wrote:
>> Here are some comments on a fresh install of 0.6d5.  (Some things go by
>> quickly so it is hard to record them.)
>> There was a complaint about /var/lib/pgsql/data missing.
>> There was a complaint about upgrading moodle.
> That should be fixed with the latest moodle-xs, but that is not on the
> iso, atm... You should boot in single mode and start the network to get
> internet access.

the connection to the internet on eth0 is fine.

>Then do a yum --enablerepo=olpcxs-testing update to
> grab the latest packages.

OK I'll try this after I sort out the lan side of the networking.

>> The release notice says 9-0.5.2, but I'm pretty sure is was 0.6d5 and
>> xs-config on disk is
>> Says to run network_config and domain_config before dhcp will work.  The 
>> box
>> has 3 nics, but the 2nd one, for attachment to an AP, was not connected 
>> at
>> the time of the install and first boot.
> What is the third nic for, anyway?

I was thinking of two physically separate lan segments.  Also, the box is 
dual boot and the third nic is used in the other configuration.

> So, the XS that is pre-configured to have the AP on "eth1", part of
> lanbond0, but eth1 was not present at install time, perfect..

eth1 was physically present in the box.  it just didn't have anything 
connected to it.  I supposed that the server could be installed before the 
ap was attached. Is it necessary to have the AP attached and powered up 
during the install?  What IP address should the AP have in order not to bump 
into the XS's dhcp and still be on the proper subnet?
> What is the output of:
> cat /etc/udev/rules.d/70-persistent-net.rules

# VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] (rule written by 
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", 
ATTR{address}=="00:17:9a:bb:e5:8d", ATTR{type}=="1", KERNEL=="eth*", 
# VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] (rule written by 
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", 
ATTR{address}=="00:1b:11:c3:74:e0", ATTR{type}=="1", KERNEL=="eth*", 
# VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] (rule written by 
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", 
ATTR{address}=="00:17:9a:bb:e4:1e", ATTR{type}=="1", KERNEL=="eth*", 
[root at schoolserver ~]#

> You can swap eth1 and eth2 in that file to rename the interfaces, if
> eth1 is not the nic to your AP.

I tried the AP on both eth1 and eth2; didn't seem to make a difference.

> Stop the network before you edit, then reboot after your done editing..
>> Says no domain so can't start ejabberd.  I take it this is the 
>> instruction
>> at http://wiki.laptop.org/go/XS_Installing_Software to Set the fully
>> qualified hostname of the machine by editing /etc/sysconfig/network.
> After the "yum update" that should not be required.

Is running /etc/sysconfig/olpc-scripts/domain_config <hostname> still 

>> I then connected a non-WAN port of the AP to eth1 and rebooted.  Still no
>> dhcp.  service dhcpd status again tells me to run network_config and
>> domain_config  (I take it these are the ones in
>> /etc/sysconfig/olpc-scripts.)  I also tried eth2.
>> edited /etc/sysconfig/network as indicated.
>> ran network_config and domain_config  ( though
>> http://wiki.laptop.org/go/XS_Installing_Software says this is not longer
>> necessary)
>> this changed HOSTNAME to schoolserver.random.xs.laptop.org,
> What did you pass to domain_config as the domain name? If you leave it
> blank you get the default of "schoolserver.random.xs.laptop.org"
You're right.  I left it blank like the example in the docs.  I did put 
schoolserver.localdomain in /etc/sysconfig/network, but that doesn't seem to 
have done anything.

>> but still no
>> dhcp; same message about running network_config and domain_config .
> What is the output of:
> cat /etc/sysconfig/xs_server_number

[root at schoolserver ~]# cat /etc/sysconfig/xs_server_number
1[root at schoolserver ~]#

> cat /etc/sysconfig/xs_domain_name

[root at schoolserver ~]#  cat /etc/sysconfig/xs_domain_name
cat: /etc/sysconfig/xs_domain_name: No such file or directory

> cat /etc/sysconfig/xs_network_config

[root at schoolserver ~]# cat /etc/sysconfig/xs_network_config
# Generated by network_config
# do not edit by hand

(btw please note the broadcast addr for XS_MSHBOND0, should be

On which of these segments would I expect the AP to reside, assuming it was 
connected to eth1?

>> rebooted
>> ejabberd still says domain not yet configured
>> dhcp still asks me to run network_config and domain_config
> need above info,
> Jerry

More information about the Server-devel mailing list