[Server-devel] Browsing school server

Martin Langhoff martin.langhoff at gmail.com
Sat Jan 17 17:41:15 EST 2009

On Sat, Jan 17, 2009 at 8:05 PM, David Leeming
<leeming at pipolfastaem.gov.sb> wrote:
> I am aware of what Moodle can do but disagree that file access should always
> be through it. It's much easy to go straight to the folders of content
> rather than having to log on and enrol on courses etc.

I agree. Consider that Moodle - with the appropriate patches written
by yours truly - does let you run webdav for file upload and
management, *and* lets you browse the files without "seeing" moodle
around them. No "login", no "enrol" into courses.

The reason to leverage moodle for this is that it handles the
authentication for us when it comes to file upload and management.

(In other words, we *could* use apache's webdav, but then we get into
a bad mess of account management with funny htaccess files.
Maintaining serveral DBs with the same data... on the same server, and
writing code to keep it all in sync is... life's too short for that.
In other words: Moodle's roles/capabilities infrastructure is what I
am mainly wanting to reuse/leverage here.)

> The who.php page is the first page that comes up and that's where one makes
> the decision about what one wants to do - use Moodle or not.

That's a _wart_ of the current implementation. Horrible. I'm ashamed.
It'll disappear and I'll pray for forgiveness.

> So that's where
> I need to add the link, or otherwise change the page that comes up when one
> clicks on "Local School Server" on the Xo browser.

If you follow my hints to put that link in the theme file, the file
will appear right there, and in a few other useful places too ;-)

> As I said, I have reinstalled 0.5-1 twice and same result. I haven't tried
> to revert to 0.5-0 to re-confirm that I don't have the same issue, will try
> and do so later this week.

That's weird. I am starting to suspect that the disk you have labelled
"0.5-1" has some odd version of the xs distro. What I think of when
you say "0.5-1" is actually "0.5.1-dev03". Now, you've said a few
times that your connection is limited in the Pacific, so perhaos you
are still using an earlier 'dev' version.

That's ok, you can install any 0.5 - but then, right after the
installation, you need to have the XS connected to the internet, and

  yum --enablerepo=olpcxs-testing update

to bring it to the latest "0.5.1" candidate. In any case, a good way
to understand what version of XS specific things you have is to see
the output of

  rpm -qa xs-* ejab* moodl* idmgr | sort


 martin.langhoff at gmail.com
 martin at laptop.org -- School Server Architect
 - ask interesting questions
 - don't get distracted with shiny stuff  - working code first
 - http://wiki.laptop.org/go/User:Martinlanghoff

More information about the Server-devel mailing list