[Server-devel] eth0 static IP requires /etc/sysconfig/olpc_net_config

Tony Pearson tpearson at us.ibm.com
Tue Jul 1 10:04:39 EDT 2008

> From: "Martin Langhoff" <martin.langhoff at gmail.com>
> Subject: Re: [Server-devel] Laptop XS working
> To: "Phill Hardstaff" <phillh at spc.int>

> The XS has (or should have) 2 network interfaces.

>  - eth0 is the internet / wan connection. It defaults to doing dhcp,
> if you need to set it to a static ip address, edit
> /etc/sysconfig/network-scripts/ifcfg-eth0

For static IP you also need to create a file, which I did as 

[root ~]# echo "# created by Tony" > /etc/sysconfig/olpc_net_config

It doesn't matter what the contents are, however, XS checks for this file, 
and if it doesn't exist,
copies over your ifcfg-eth0 with pre-defined DHCP ones.  The original idea 
I presume was that
after it copies over the DHCP it would create this file to turn off the 
process and only do it on the
first boot, but in my case, that file never got created, and all my work 
setting up static IP was
over-written each time.  Creating this file solved the problem.

Martin, would you like me to file a "bug" on this?


Tony Pearson
Senior Storage Consultant, IBM System Storage?
Telephone: +1 520-799-4309 |  tie 321-4309 |  Cell: +1 520 990-8669
email: tpearson at us.ibm.com |  GSA: http://tucgsa.ibm.com/~tpearson
Blog: http://www.ibm.com/developerworks/blogs/page/InsideSystemStorage
AKA: 990tony Paravane, eightbar specialist 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.laptop.org/pipermail/server-devel/attachments/20080701/3737feda/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/jpeg
Size: 3808 bytes
Desc: not available
Url : http://lists.laptop.org/pipermail/server-devel/attachments/20080701/3737feda/attachment.jpeg 

More information about the Server-devel mailing list