[OLPC New Zealand] Testing Summary: 21 January 2012 - Auckland, New Zealand

Tabitha Roder tabitha at tabitha.net.nz
Sat Jan 21 04:30:23 EST 2012

Testing Summary: 21 January 2012 - Auckland, New Zealand
Who: Fabiana, Oliver, Tabitha, Tom.

Tested Build 25 on XO-1.75 B1 and C1 prototypes. Firmware Q4C12.
Looked specifically at sleep/resume today as this build has some fixes. The
"QR code" mouse pointer issue is fixed, as are the dots around the mouse
pointer. However, suspend and resume generally is quite unstable. The AVC
touchpad on Kid appears to work better out of the box now.

XO-1.75 C1 - Sundance - Enabled power management (tick in first box only).
Tested the sleep restart while using Implode. Waited for sleep to start
(light goes off) then tested wake up by moving the cursor using touchpad,
cursor was fine. On second sleep it froze and power light stayed on (we
weren't looking at the screen when this happened). When you press the power
button the power light goes out briefly but the laptop does not respond.
You have to hold down the power button to switch it off.

This also happened on Bonnie and led us to somewhat reliable steps to
reproduce. The screen goes black on Bonnie during suspend and sometimes it
goes black some (4 to 9) seconds before the power light starts flashing. If
you trigger a resume with the touchpad immediately after  screen goes black
but before the power light starts flashing, the laptop freezes as described
above. We were able to repeat the freeze 3 or 4 times in a row by doing
this on Bonnie. It seems easier to provoke a delay between the screen going
black and the power light flashing by starting the laptop with power
management turned off and then turning it on.

Clyde ended up in a similar frozen state without an obvious link to suspend
and resume: while using record, we took two photos, a low quality and a
high quality video and then we did an audio recording, when we pressed the
red stop button the laptop froze with the same power light flashes off when
you press the power button that we see on the suspend/resume freeze.

Kid froze in a slightly different way, after pressing stop in paint and
then pressing the tick on the journal details the laptop froze. It
superficially looked like the same as above, but after a while and many
presses of the power button, the laptop shut down normally.

We also had Clyde freeze during suspend/resume. The power button does the
flash off thing and the laptop does not respond to the power button. Clyde
also suspends with a black screen with the backlight on -- is this a no
dcon thing?

On one occasion using Record, Clyde froze with the preview video still
running, the force quit dialog appeared when we tried to stop it. Exited
normally after force quit.

High quality video still stops working after about 10 seconds of recording.

On a couple of occasions record did not save anything to the journal even
though we took many still pictures which appeared along the bottom of the
screen. We did not have time to investigate this and will look at it next

Bonnie got into a strange state. Log and Terminal were running and Image
Viewer was pulsing in the frame. Clicking record in the ring does not start
record. There are exceptions in the log. I believe I got into this state by
starting the laptop, viewing logs with terminal and log, opening a picture
from the journal and then closing Image Viewer. The following exception
occurred every time we clicked record in the ring:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/desktop/favoritesview.py",
line 487, in __button_release_event_cb
  File "/usr/lib/python2.7/site-packages/jarabe/desktop/favoritesview.py",
line 499, in _activate
  File "/usr/lib/python2.7/site-packages/jarabe/desktop/favoritesview.py",
line 492, in _resume
    misc.resume(journal_entry, self._activity_info.get_bundle_id())
  File "/usr/lib/python2.7/site-packages/jarabe/journal/misc.py", line 231,
in resume
  File "/usr/lib/python2.7/site-packages/jarabe/journal/misc.py", line 258,
in launch
AttributeError: 'NoneType' object has no attribute 'activate'

Write on Sundance froze the whole laptop when the baby slapped the
keyboard. The power button triggers the normal shut down sequence. We were
unable to reproduce this.

We solved a mystery with Speak's Robot. On Clyde, the robot is quite stupid
but on Kid the robot knows many things and even tells jokes. After
examining the log we see that different brains are loaded on each laptop
and after examining the code we see that the brain is selected according to
the free memory. Clyde only has 512MB memory so does not get the "clever"

Kid - started and did basic play test of the following activities: Measure,
Fototoon, Infoslicer, Wikipedia EN, Write, Browse, Chat (with one other),
Labyrinth (didn't test adding image), Stopwatch, Finance, Typing Turtle,
Paint, Physics, Ruler, Help, Clock (weird that first time it writes right
aligned then changes to always write centred), Moon, Terminal, Memorize,
Maze, Tam Tam Mini, Implode.
Used Get Books on Kid to download "A Little History of the Great World War"
by Isaac Marshall Page - it opened in Read but very very slowly. Each page
had to load and it seems that maybe each page was an image saved as one big
.pdf file. The Get Books activity icon did not change colour in the
activity ring to show it had been used, but the Read activity icon did
change colour.

Clyde - started and did basic play test of the following activities:
Wikipedia EN, Tam Tam Mini, Fototoon, Physics, Ruler, Help, Clock,
Stopwatch, Moon, Terminal, Implode, Maze, Browse.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/olpc-nz/attachments/20120121/413977a6/attachment.html>

More information about the OLPC-NZ mailing list