[OLPC New Zealand] Testing Summary: 2 July 2011 - Auckland, New Zealand

Tabitha Roder tabitha at tabitha.net.nz
Sat Jul 2 06:16:44 EDT 2011

Testing Summary: 2 July 2011 - Auckland, New Zealand
Who: Abishek, Ashley, Kadin, Nevyn, Noel, Oliver (he pretty much slept
through the whole thing), Susan, Tabitha, Tom, Tommy,
Testing notes refer to XOs by nicknames.

"Tux" XO-1.0 running 11.2.0 release candidate 2 build 871
Maze works
Implode works
Record works - tested create image, video, audio
Calculate 37 broken - answer does not have superscript so formula appears
incorrectly, reported last week
Memorise - works

"Monkey" XO-1.0 running 11.2.0 release candidate 2 build 871
on first reboot after flashing it didn't start correctly, just stalled on
the XO image
Turtleart - made images from Journal appear in random places successfully
Clock is in American format (month before date) regardless of country
settings - tried English Australia,
Surprised by the languages list, no English UK yet 5 varieties of German
Changed timezone to Auckland successfully

"Shadow" XO-1.5 running 865 10.1.3-au3-rc1 (rc2 not ready at time of
trouble after flash, it booted, did firmware upgrade and said restarting but
then hung. Holding down the power button didn't cause it to shut down, we
had to drop the battery. Seemed to behave normally after that. Shadow is an
XO 1.5 B2.

"Shrek" XO-1.0 running 11.2.0 release candidate 2 build 871
trouble with the zoomable interface keys

"Ivy" XO-1.5 running 865 10.1.3-au3-rc1 (rc2 not ready at time of testing)
Typing turtle works, hands too big
Clock - talking clock didnt talk, checked volume in frame not muted, checked
have sound in other activities
Deducto - text doesn't fit in the buttons in sample mode
Tux Math Factoroids has no limit on the speed of the spaceship. When moving
fast, collision detection doesn't work and you can fly through the asteriods

Testing collaboration on os871, XO-1.0, mesh network:
Started chat on Shrek, Mojo, Tux and Monkey joined, everything seems to work
Stopped chat on Shrek, activity disappeared from neighbourhood view but
continues to work on remaining participants
Mojo Invited Shrek from the neighbourhood view but nothing happened on shrek
This seems to be very reproducible

Tested collaboration with Write and two os871 XO 1.0s, things seemed to
behave reasonably normally. I had one laptop never join the collaboration
when it re-joined after leaving -- it had the text as it stood when it left,
but it never got any updates from the laptop which originally started the
colaboration. I was unable to reproduce this. I found a large stack trace in
the logs from the first startup which might be related? See attached.

The following error appears in shell.log on all our os871 XO 1.0 a regular
1309568997.022151 ERROR dbus.connection: Exception in handler for D-Bus
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 214, in
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/jarabe/model/neighborhood.py", line
430, in __buddy_info_updated_cb
    self.emit('buddy-updated', self._buddy_handles[handle], properties)
KeyError: dbus.UInt32(3L)

Power logs attached.

Abacus (on "Tank" XO-1.5, build unknown so these bugs may not apply anymore)
- resizing of the font to fit (in between the top and bottom rods where it
displays each column number), still doesn't fit, red marker across top of
rods goes off the screen both sides - if dragged off you can't drag back

Talked about Software Freedom Day - time to start planning!
Talked about attending Barcamp 16 July 2011 - http://bca.geek.nz/ - plan to
take XOs so won't be testing at the Windsor on 16 July.

Thanks testers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.laptop.org/pipermail/olpc-nz/attachments/20110702/ff0f3cb1/attachment-0001.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: org.laptop.AbiWordActivity-1.log.bz2
Type: application/x-bzip2
Size: 8438 bytes
Desc: not available
Url : http://lists.laptop.org/pipermail/olpc-nz/attachments/20110702/ff0f3cb1/attachment-0002.bin 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: power-logs.tar.bz2
Type: application/x-bzip2
Size: 11138 bytes
Desc: not available
Url : http://lists.laptop.org/pipermail/olpc-nz/attachments/20110702/ff0f3cb1/attachment-0003.bin 

More information about the OLPC-NZ mailing list