[olpc-nz] Testing summary - Auckland New Zealand, 25 September 2010

Tabitha Roder tabitha at tabitha.net.nz
Sat Sep 25 05:10:42 EDT 2010

Testing summary - Auckland New Zealand, 25 September 2010
Who: Fabiana, Calvin, Leslie, Liz, John, Nevyn, Robin, Tabitha, Tom

failed to start, both copying to journal and trying to start from USB on
os373pyg, got logs
Tried on build 852 but it still didn't work
No icon appears in the activity ring on either build


Tested backup-4 and restore-3 on 2 XO-1.0s with 1 USB stick
Backup: you have to choose the storage device then press the button that
looks like keep
it then says "backing up Journal to /media... etc
Shows x/x number of files but gives no message to say when backup is
complete, it did create a backup onto the usb and named it with the XO name
and some numbers with .xmj extension
Restore: opened activity and it says "no bundle selected. please close this
activity and choose a bundle to restore from the journal"
Tried to click on the file on the usb that says it is the journal backup for
this laptop - it seems to open the restore activity but hard to tell as not
labelled as such in the frame
found a restore journal button in the activity, clicked it and get the
message "restoring journal from
/home/olpc/.sugar/default/data/" a whole lot of numbers then ".xmj"
- that file location is not the usb drive, so we assume that opening the
file on the usb is actually copying it to the journal
Tried to restore the same journal file on another XO but it doesn't let you
(deliberate we think)
Second XO Backup: Tried backing up this second XO onto usb, then deleted
most of journal. Ran the restore and it seems to work but it on both XOs we
get two copies of the .xmj journal backup file in the Journal.
Found another option for restore - in the Journal you can use the arrow
right to get to the kind of more information view (with a preview,
description and tags) and then where the play button (start)
is a drop down option of restore appears
Basically they worked, though it was a bit confusing that you don't open
restore and then choose the file on the USB.  Some instructions for the user
might be helpful - when you open the backup activity would be good to click
a question mark and see explanation of activity, like what happens in the
finance activity. Also, there was no obvious notification that the backup
file creation was completed.


Turtle Art 99
First a question - what is the difference between turtle art and turtle
Installed on os373pyg XO-1.0 and a few os852 XO-1.0s - seems to rename
itself to turtle blocks
Found some XOs have a different display to others, on build 852 it has menus
and on build 373pyg it has buttons. There is no erase option on the turtle
activity in the list view of all the activities in dextrose 373pyg, however
there is an erase option for turtle activity on os852. Although they are
both showing as version 99 they are different which is a bit confusing.
Moving the blocks around we were not sure what to do if you could not see
the start block anymore (dragged off the screen and it is hidden by the
buttons). Tried using the full screen option, hide/show blocks, didn't help.
Found resize so blocks very big helped, then dragged them about before
resizing back to small blocks. It would be good if there was a limit to the
location of blocks or if you could change your view coordinates or if there
was a reset blocks to left/right/middle button, or a resize blocks to fit
the screen button (perhaps in the view tab).
Tried to test turtle art / blocks 99 in german and spanish but there is no
german and there are lots of spanish options. Guessed a Spanish translation
to test.

Here is Fabiana's report on turtle art:

> Loads as turtle blocks. It was a bit confusing at first.
> Created a path, and moved it up, but the 'start' went off screen and now I
> have
> Set language to Spanish (argentina). Repeated with setting language to
> Spanish (Bolivia).
> On actividad tab, mouse over on the turtle icon on top reads "tortuga
> alenta' I guess it is meant to say 'tortuga lenta' (slow turtle)
> On the turtle palette, block labelling: The clean button reads 'limpia'
> which is not an infinitive. (the infinitive is 'limpiar') while the rest of
> the verbs are in infinitive.
> In the colour palette black and white show as 'black' and 'white' instead
> of 'negro' and 'blanco'
> In the  'box' pallette 'turtle shell' not translated
> In the 'journal' palette: 'oculta bloques', oculta is not an infinitive,
> should be 'ocultar'
> In the help menu, the mouseover on the turtle pen etc is not fully
> translated: Eg: torguga: paleta the comandos de la tortuga is ok, but then I
> get pen: paleta de ordenes de la pluma (should read pluma: paleta de ordenes
> de la pluma) The only one fully translated is the 'turtle' one.
> Opened a file that i had created and saved in 'english' it loads already
> translated to spanish. (which is good)


Here is Tom's report on collaboration:

> Tested collaboration on os852. Started off with send to friend.
> 1 Created a picture in record
> 2 Closed record activity
> 3 Renamed record activity in journal to "picture for anna" (you can see
> where this going)
> 4 Sent "picture" to anna (another xo)
> 5 Picture loads in "Browse" but is a whole lot of xml
> It turns out that we were sending the "activity" not the results of the
> activity. After sending the picture itself, things worked a lot better.
> Should it be possible to send a session of the Record activity to a friend?
> If so, should it load in Browse or in Record? I guess this is a special case
> of, should activity sessions be stored in the journal? Especially a
> relatively stateless activity like Record?
> While rummaging around in the logs, found a strange exception with the
> network manager, http://bugs.sugarlabs.org/ticket/2369 and many more that
> I didn't report (next time).

Another full on testing event. Thanks everyone.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.laptop.org/pipermail/olpc-nz/attachments/20100925/6c99d711/attachment-0001.htm 

More information about the olpc-nz mailing list