[olpc-nz] Testing summary - Auckland New Zealand, 5 June 2010

Nevyn nevynh at gmail.com
Sat Jun 5 04:44:39 EDT 2010

On Sat, Jun 5, 2010 at 2:53 PM, Tabitha Roder <tabitha at tabitha.net.nz> wrote:
> * Asus Eee 1001HA x 2
> No sound in Record - card Intel Corporation N10/ICH 7 Family High Definition
> Audio Controller (rev 02)

Suspect this may be a microphone issue - if we're unable to record,
then playing back silence is only going to result in silence...

> Sound works in TamTam Mini version 52.
> No wireless - it has this card
> 02:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe
>     Subsystem: Device 1a3b:1087
>     Flags: bus master, fast devsel, latency 0, IRQ 17
>     Memory at fbff0000 (32-bit, non-prefetchable) [size=64K]
>     Capabilities: <access denied>
>     Kernel driver in use: rt2800pci
>     Kernel modules: rt2800pci

To be fair the issue is that the wireless drivers aren't in the kernel
yet. The kernel module needed for this card can be found here:
http://www.ralinktech.com/support.php?s=2 . At some point I'll install
a build environment (i.e. gcc), compile and install the driver and see
if the drivers work with some of that SugarOS goodness. (Still haven't
had a chance to see any of the collaboration sexyness of SugarOS)

> Social calc version 5 failed to launch correctly - get a white screen with
> just the frame at top displaying activity name, share icon, keep and stop.
> Got logs. Tried again later and it works.

I did have a look at the logs and repeat the excercise while looking
at when the entries showed up in the logs. When closing Social Calc
the errors displayed in all of the logs (when social calc failed and
when it ran) but only on close. In otherwords, the log did not appear
to give much of an indication as to why social calc may have failed to
open properly. Did not see the failure myself.

> Typing turtle version 26 worked but it was extremely fast

This was probably my fault - was well impressed with this as it is
sufficiently challenging at it's highest levels. Have just had another
look. Seems fine. Just a thought - does anyone know if typing turtle
can be used for learning a dvorak keyboard?

> Write version 69 - tested the font sets and found problems with Hershey
> fonts. Tested other formatting options - sizes, colours, bullets and
> numbers, B,I,U, all okay.
> Tux math version 1 - does not start - gives error message "failed to start"
> - got logs
The error screen seems to be the generic splash behind the
application. The logs state missing libSDL_Pango.so.1 so simple
dependancy error.

> Poll version 26 - launched successfully. No further testing done.
> Scratch version 12 - launched successfully and basic script worked.
> Finance version 3 - launched successfully. No further testing done.
> Record version 66 - launched successfully. Could see self in video and
> picture. Saved a picture and video. Sound failed.
> Terminal version 31 - launched successfully. Used it successfully.
> Abacus version 9 - liked it, particularly build your own.   :-)
Can't over state this enough. Awesome! Binary abacus. I'm building one!

> F7 is backlight key. F11 and F12 alter volume. F1 to F4 change views. Found
> "alt shift f" gives us frame and "alt shift o" gives journal search.
Slight amendment - Fn-F7 was backlight, all others no need for Fn key.
None of the other ACPI kyes appear to be intercepted. i.e. can't
adjust brightness.


More information about the olpc-nz mailing list