[OLPC-AU] Testing summary, Auckland - 17 March 2012

Tabitha Roder tabitha at tabitha.net.nz
Sat Mar 17 05:31:19 EDT 2012

Testing Summary, Auckland - 17 March 2012
Who: Fabiana, John, Oliver, Rachel, Tom

Tested build “30 customized” on XO-1.75 and “build 206 11.3.1-au” on XO 1.5.

XO-1.5 Summary (details below):
Power saving blanks the screen while recording a video
Terminal font still too big
Jigsaw puzzle quite slow for complex puzzles
Saving custom Memorize games still a problem
Shared memorize had lots of Ivy’s clustered around it in the neighbourhood
Flipsticks doesn’t work so well
Visual match style changes don’t work

XO-1.75 Summary (details below):
B1 clock reset breaks yum, makes recovery more difficult
Browse crashed, gained some insight into google docs stability
Chat is much less chatty on the network when used with the
schoolserver, suspend and resume really really good in this situation.
Maze crashes immediately when collaborating

Power logs attached.

build 206 11.3.1-au on XO 1.5:
Record activity - works fine for photo and video. high and low res.
even long ones. But quite quickly the screen goes black - it is not
going to sleep - there is no flashing of the power light and it
continues recording. On Ivy it takes 1 minute to go black. Tabitha
raised the issue that since the screen goes black you might not know
you are being recorded and that might not be a good thing.
On on occasion on Ivy, record showed the preview (with a line of
“noise” pixels at the bottom), but the preview went black during video
recording and the camera light went out. Pressing stop left a busy
pointer. Record exited normally. Log is attached.

Paint: Seems to be working ok.

Terminal: The font is too big - true that hitting the zoom button can
make the font smaller, but the large default font makes the welcome
screen look awkward as the ‘welcome children of the world’ sentence
breaks in a wierd place and this remains after zooming down.

General: The time to ‘sleep’ seems really fast. Even leaving the
laptop unattended for a short time turns the screen black which I find
quite annoying.

Stopwatch - seems to work but I still think it would be nice to be
able to save the times that were marked to use in a different actiity
(like write, to write a lab report) Seems silly that I would have to
write that on paper to transfer to a document.

Calculate: basic functions seem to be working ok. Sort of odd that
when I get an error message not all letters in the message are the
same colour.

Physics: Still have trouble drawing short lines - i see the cursor
track but dont get a line drawn. Is there a minimum length it expects?

Jigsaw puzzle - too much lag when trying to move the pieces - makes it
very difficult to play. This seems to be a problem as the number of
pieces of the puzzle increases (not a problem in the setting for few
puzzle pieces).  When I start the actiivty and choose a puzzle it will
not show me the puzzle when I hit solve - need to hit shuffle. Same
with Slider Puzzle activity.

n Editor: When I mouseover the scissors, the drop down covers the
first  3 lines of text - makes it difficult if one is trying to work
on those particular lines. Otherwise seems to be workinng ok.

Compris Click game - seems ok.

Poll: I can build a poll but after I close, I don't seem to be able to
find it. Where is the ‘choose a poll’ point to? I did save my poll....
I can, however, reopen it from the journal, but it would be useful to
see it on hte choose a poll when i start poll again (I am not starting
as ‘new’).

Measure: Seems ok.

Slider Puzzle activity: When I start the activity and choose a puzzle
it will not show me the puzzle when I hit solve - need to hit shuffle.
Just like with jigsaw.

Ivy: GCompris click game - when you shut off the lid, the game seems
to continue to play cause the computer keeps making giggly noises -
seems like a waste of battery.

Memorize - really struggle with saving the games you create yourself.
It is not user friendly or intuitive. Found that the only method that
did reliably save your game in the Journal was if you clicked on one
pair of tiles and then clicked on “update this pair”. That doesn’t
seem a relevant method to save the game in the Journal. We spent quite
a lot of time on this using Ivy and Poppy. We wanted to easily be able
to save games that we make for each topic we are studying (so you can
set a homework task to create these games and then share them with
your classmates the next day in each class).

Shared memorize on ivy on adhoc network and ended up with 6 ivy’s
around the memorize activity! Not sure how this is possible, see:

TuxMath (Ivy) worked. Suitably irritated everyone around.

Cartoon Builder (Ivy) worked. Again, it irritated everyone around,
other than the baby who loved it for about two minutes.

Flipsticks (Ivy) sort of crashed. I posed the stick figure and saved
different poses in each keyframe. Played the frames, changed the
speed. Got black screen. Managed to get to activity ring and start
Terminal to type Top. Found X using 75% of CPU and Flipsticks using
20% of CPU. Waited a long time and eventually got the Flipsticks
screen back, sort of. But the stick figure was moving along half off
the screen which didn’t match the keyframes. On a restart I can reset
the position in each of the keyframes but wonder how they all were

Poll (Ivy) works. Would be neat if you could create a poll where the
participants had to choose their answers in order of preference. e.g.
Put the colours into a list from the most liked to the least liked.

Maze (Ivy) worked.

Moon (Ivy) worked.

Numbers (Ivy) worked. Got a bit muddled when I was thinking about
BEDMAS but found the game knew what to do so I just had to do my
things in order. e.g. number required was “30” and you have “3 3 7” to
use, so you have to make “3+7=10” then you can make “3x10” as if you
do “3+7x3” you don’t get the right answer. Perfect.

Visual Match (Ivy) broken. The button with the 5 escaping from a box
has a whole lot of other game styles on it’s sub toolbar but they all
just cause a reshuffle with no change in the tiles.

Gcompris clickgame (Ivy) - interestingly we could hear this playing
its sounds while we were not using it (yes, I was playing with the
baby). The game didn’t seem to sleep when the computer was idle.

Clock (Ivy) worked.

Ruler (Ivy) worked.

Terminal (Ivy) starts. No further testing done.

Paint (Ivy) tried most tools but not all, found all that I tried
worked. For the first time, I have noticed that the greyscale button
and the rainbow button being next to each other suggests they are
similar tools when in fact they are not. The greyscale button strips
the colours out of your picture. The rainbow button gives you a
rainbow coloured pen to draw with. Maybe they should not be situated
next to each other.

power logs were not collected last week because my power log collector
attempts to mount ext3 and the filesystem is ext4 and somehow
incompatible. Removing the manual filesystem type option to mount
fixes the situation. I don’t know why I set this option in the first
place? Maybe it makes mounting faster? or it’s only needed on XO-1?
Will test that shortly.

XO-1.75 os30 testing for OLPC
Discovered one reason for the erratic behavior of yum on XO 1.75.
Bonnie fairly regularly looses the time (known problem in the B1
prototypes), resetting to January 2000, when you use yum to get
ntpdate to fix the time, yum fails with a cryptic message:

[olpc at xo-6d-6c-3a ~]$ sudo yum install ntpdate
Error: Cannot retrieve repository metadata (repomd.xml) for
repository: fedora. Please verify its path and try again

Using tcpdump and wireshark we find that the reason is that the
certificate on mirrors.fedoraproject.com is not valid until some time
after the year 2000. Maybe we should install ntpdate by default?

Browse on os30 hung while entering my google password, unfortunately I
wasn’t able to diagnose. The “do you want to save this password”
dialog appeared and wouldn’t go away, with the refresh of the browser
itself behind stuck. The force quit dialog appeared in Portuguese and
I chose the wrong option and killed it :(

Chat on os30 with schoolserver produces far less traffic than on os29
on adhoc network. We could wait for a laptop to go to sleep and then
send a message in chat and within a second the other laptop wakes up,
receives it and goes back to sleep! Chat seems to have no problems
with sleep or latency when used with schoolserver.

Discovered a possible reason for unstable google docs on Browse on XO
1.75 -- if someone types fast enough into the doc on another computer,
Browse can’t keep up, you can watch their changes coming in a couple
of words at a time (including words which then get deleted) with a
delay of a couple of minutes. I suspect it will recover if the other
user stops typing for long enough but we didn’t wait long enough. This
would explain why sometimes it works and sometimes it doesn't -- it
depends on how fast the changes come.

Maze crashes almost immediately when you collaborate, I think we
reported this before? There is an exception in the logs (attached).
This happens on all versions we’ve tried recently, not just os30.

Had record crash once after playing a video.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: vu.lux.olpc.Maze-1.log.bz2
Type: application/x-bzip2
Size: 1484 bytes
Desc: not available
URL: <http://lists.laptop.org/pipermail/olpc-au/attachments/20120317/53821cd9/attachment-0003.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: org.laptop.RecordActivity-1.log.bz2
Type: application/x-bzip2
Size: 2054 bytes
Desc: not available
URL: <http://lists.laptop.org/pipermail/olpc-au/attachments/20120317/53821cd9/attachment-0004.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: power-logs.tar.bz2
Type: application/x-bzip2
Size: 62755 bytes
Desc: not available
URL: <http://lists.laptop.org/pipermail/olpc-au/attachments/20120317/53821cd9/attachment-0005.bin>

More information about the OLPC-AU mailing list