[Etoys] can't install Squeak on Ubuntu 7.10 -- could not find display driver vm-display-X11

Bryan Berry bryan at ole.org
Tue Nov 13 00:41:45 EST 2007

I have been trying to install Squeak on Ubuntu 7.10 w/out success

I was able to install it w/ Debian packages but the sound didn't work.
At the advice of my colleague Luke Gorrie I tried installing it from the
VM-Source tarball

I used the documentation in /unix/doc/HowToBuildFromSource.pdf

I ran the configure script and got an error that it couldn't find
npsqueak libraries.

I then tried ../config/configure --without-npsqueak

it configured but this showed up in the config.log

configure:26825: result: ******** disabling vm-display-X11

I then did make and make install

Predictably, I get this error when I try to open a squeak image

$ squeak olenepal-demo.4.image 
could not find display driver vm-display-X11; either:
  - check that /usr/local/lib/squeak/3.9-8/vm-display-X11.so exists, or
  - use the '-plugins <path>' option to tell me where it is, or
  - remove DISPLAY from your environment.
Aborted (core dumped)

Please assist :)

What's the best place to look for documentation on Squeak installation?
I found some in the Squeak wiki, OLPC wiki, and a few other places but
no single comprehensive resource. I will try to add notes on how to
successfully install Squeak on Ubuntu 7.10 onto the OLPC Wiki once I can
successfully install it myself :

Help! Part of my job is to teach people how to use Squeak so our
development team (the real programmers) can focus full-time on
developing learning activities w/ Squeak. I need to get up to speed on
Squeak quickly.  Thanks

Bryan W. Berry
External Relations Manager
OLE Nepal, http://nepal.ole.org

More information about the Etoys mailing list