[Etoys] Greek and other languages support

spyronis at ceid.upatras.gr spyronis at ceid.upatras.gr
Mon Dec 10 14:31:12 EST 2007

>> >     4. Evaluate:
>> >
>> > 	TTCFontSet installExternalFontFileName: 'GreekTT.out'.
>> >
>> >       to load the font file.
>> >
>> >     5. Evaluate
>> >
>> > 	newID := LocaleID isoString: 'el'.
>> > 	t := InternalTranslator
>> > 		newLocaleID: (LocaleID isoString: 'el').
>> > 	NaturalLanguageTranslator translators at: newID put: t.
>> > 	Locale switchTo: (Locale localeID: (LocaleID isoString: 'el'))
>> >
>> >      in a workspace.
>> >
>> How/Where steps 4,5 are done??
>   "Workspace" is a kind of command line interpreter where you can type
> and evaluate Smalltalk code snippet.  (It is just a text editor,
> actually but this is one way to look at it.)
>   The developer's image available at:
> http://tinlizzie.org/olpc/etoys-dev-2.3-1815.zip
> is a good start.  Launch the .image in it by double clicking or
> executing command like:
>   % squeak etoys-dev-2.3-1815.image
> Make sure the computer is connected to the Internet, and press "load
> code updates" button near bottom-left in the Squeak screen.
>   Then, click on the empty area in the Squeak screen.  You have
> "open..." item in the "World" menu that pops up.  Click on "open..."
> and you get "workspace (k)" in the menu.  If you click on the menu
> item, you should get a white/gray window in the Squeak screen.
>   Copy and paste the above expressions into the workspace, and select
> the text you want to evaluate by dragging the area by mouse.  (The
> selection should be green.)  Then press "Alt-d" (i.e., hold Alt key,
> and hit "D" key).
>   4. will take some time (like 45 seconds).  Be patient.
> -- Yoshiki
> _______________________________________________
> Etoys mailing list
> Etoys at lists.laptop.org
> http://lists.laptop.org/listinfo/etoys

Thanks a lot for the infos.. they worked..
There are also some issues..

The 7 greek vowels take sometimes accents such as έ,ά,ό,ί,ή,ώ,ύ
The caps also: Έ,Ά,Ό,Ί,Ή,Ώ,Ό.
[Accented greek words produced when pressed ' and then the vowel]

In small caps all are supported except: έ.
In caps the only one supported is Ώ.
[note that when i type ' (accent) and then ε or E,A,H.. it appears a space
character and then the accent ']
same happens to translated .po text]

Another issue is how possibly can this work in linux squeak VM ?? (VM for
the OLPC)
What changes have to be done?? Are there any manuals/help/steps which can
help me in this task??
I must also tell you that when i run the image that worked on Windows VM
it works fine in Linux VM for the .po translated text.. The problem
appears in greek input...

Thanks again, John Spyronis.

More information about the Etoys mailing list