OSBuilder for 13.2.7

Lionel Laské lionel.laske at gmail.com
Sat Sep 17 15:20:05 EDT 2016

Thanks for your answer.
I've launched 'make' because it's mentioned here [1]. But the zhashfs is
present in the bin directory.
BTW it don't works when I'm tried. The build fail on KspostStage (see full
log below).
Any idea ?


[1] http://wiki.laptop.org/go/OS_Builder/Run_on_XO_hardware#Recipe

bash-4.2# ./osbuilder.py examples/olpc-os-13.2.7-xo4.ini

 * OLPC OS builder v7.0.9

 * Running part prepare base prepare.05.selinux.sh...

 * Running part prepare sd_card_image prepare.05.zhashfs.sh...

 * Running part prepare buildnr_from_cfg prepare.10.buildnr.sh...

 * Running part prepare xo4 prepare.10.model.sh...

 * Running part ksmain base ksmain.10.core.inc...

 * Running part ksmain repos ksmain.50.repos.py...

Reading repository information for http://rpmdropbox.laptop.org/f18-xo4

Reading package information from

Reading repository information for http://rpmdropbox.laptop.org/f18

Reading package information from

 * Running part ksmain base ksmain.50.timezone.sh...

 * Running part kspkglist base kspkglist.10.core.inc...

 * Running part kspkglist base kspkglist.11.olpcupdate.sh...

 * Running part kspkglist bluetooth kspkglist.50.bluetooth.inc...

 * Running part kspkglist gnome kspkglist.50.gnome.inc...

 * Running part kspkglist osk kspkglist.50.osk.inc...

 * Running part kspkglist sugar kspkglist.50.sugar.inc...

 * Running part kspkglist xo4 kspkglist.50.xo4.inc...

 * Running part kspkglist x11 kspkglist.60.misc.inc...

 * Running part kspost base kspost.05.mount_shared.nochroot.sh...

 * Running part kspost base kspost.10.core.inc...

 * Running part kspost base kspost.10.strip_locale.sh...

 * Running part kspost base kspost.10.version_number.sh...

 * Running part kspost bluetooth kspost.50.bluetooth.inc...

 * Running part kspost sugar kspost.50.gconf.inc...

 * Running part kspost base kspost.50.lang_kbd_overrides.sh...

 * Running part kspost sugar kspost.50.misc.inc...

 * Running part kspost base kspost.50.olpcupdate.sh...

 * Running part kspost osk kspost.50.osk-config.sh...

 * Running part kspost base kspost.50.stripdebug.nochroot.inc...

 * Running part kspost gnome kspost.50.tweaks.inc...

 * Running part kspost xo4 kspost.50.xo4-tweaks.inc...

 * Running part kspost yumcfg kspost.50.yumcfg.py...

Reading repository information for http://rpmdropbox.laptop.org/f18/

Reading package information from

Reading repository information for http://rpmdropbox.laptop.org/f18-xo4/

Reading package information from

 * Running part kspost base kspost.50.zip_bootfiles.nochroot.inc...

 * Running part kspost sugar kspost.51.favoritesview.sh...

 * Running part kspost sugar_activity_group kspost.60.activities.py...

 * Running part kspost x11 kspost.60.misc.inc...

 * Running part kspost sugar_activity_group

Trying group URL http://wiki.laptop.org/go/Activities/13.2.7

Found activity group: None

Examining org.laptop.sugar.Jukebox v32:

Using cache; size and name match.

Examining org.laptop.Oficina v65:

Using cache; size and name match.

Examining org.laptop.wp-nature-images v8:

Using cache; size and name match.

Examining org.laptop.TamTamJam v68:

Using cache; size and name match.

Examining org.laptop.Chat v82:

Using cache; size and name match.

Examining org.laptop.AcousticMeasure v35:

Using cache; size and name match.

Examining org.laptop.Terminal v44:

Using cache; size and name match.

Examining org.laptop.StopWatchActivity v18.1:

Using cache; size and name match.

Examining vu.lux.olpc.Maze v26:

Using cache; size and name match.

Examining edu.mit.media.ScratchActivity v25:

Using cache; size and name match.

Examining org.laptop.HelpActivity v20:

Using cache; size and name match.

Examining info.dicts.dictionary-ml v8:

Using cache; size and name match.

Examining org.laptop.ImageViewerActivity v62:

Using cache; size and name match.

Examining org.jamendo.music v5:

Using cache; size and name match.

Examining org.sugarlabs.MusicKeyboard v8.2:

HTTP error: 404

HTTP error: 404

HTTP error: 404

HTTP error: 404

HTTP error: 404

Could not reach

 * Caught error, cleanup and then bail out.

 * Running part cleanup base cleanup.50.cleanup.sh...

ERROR: Failure in KspostStage: module sugar_activity_group, part
kspost.60.nochroot.activities.py, error code 1


2016-09-17 12:26 GMT+02:00 James Cameron <quozl at laptop.org>:

> I've never typed make.  I run the builder directly.
> On Sat, Sep 17, 2016 at 11:17:21AM +0200, Lionel Laské wrote:
> > Hi all,
> >
> > I would like to generate OSBuilder for XO-4 to create my custom build on
> a XO-4
> > using OLPC 13.2.7.
> > I've installed OLPC 13.2.7 on the XO-4 following instructions here [1].
> > I've installed os-build tool following instructions here [2].
> > But when I'm launching "make", I've got a message telling:
> >
> >    make[1]: Nothing to be done for 'all'.
> >
> > Could you confirm that the procedure described here [2] is compatible
> with
> > 13.2.7 ?
> > If no, is there anyone that could help me to update the procedure ?
> > If yes, what this message means ?
> >
> > Thanks in advance for your help.
> >
> > Best regards from France.
> >
> >          Lionel.
> >
> > [1] [1]http://wiki.laptop.org/go/Release_notes/13.2.7#XO-4
> > [2] [2]http://wiki.laptop.org/go/OS_Builder/Run_on_XO_hardware
> >
> > References:
> >
> > [1] http://wiki.laptop.org/go/Release_notes/13.2.7#XO-4
> > [2] http://wiki.laptop.org/go/OS_Builder/Run_on_XO_hardware
> > _______________________________________________
> > Devel mailing list
> > Devel at lists.laptop.org
> > http://lists.laptop.org/listinfo/devel
> --
> James Cameron
> http://quozl.netrek.org/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20160917/145fc8b4/attachment.html>

More information about the Devel mailing list