XO-4 firmware upgrade blocked by EC 0.3.04 ?

James Cameron quozl at laptop.org
Thu Jan 21 14:54:32 EST 2016

The symptoms you describe are all normal for either;

- a hung embedded controller (see 0.3.07 release notes),

- the Gold Peak LiFePO4 batteries (see 0.3.09 release notes), or

- for a communication problem (see 0.4.02 release notes and #12525).


All caused by using a prototype EC firmware version that wasn't in

The boot hang was designed by me.  It will go away once you upgrade
the firmware.  See http://wiki.laptop.org/go/12297 for details.

Please check the EC firmware version in all of your prototypes and
upgrade it.

On the machine you are having problems with, please do the following
in a normal humid environment (e.g. > 50% RH), not a dry as a bone
environment (e.g. < 25% RH); remove the power cable, the battery, wait
30 seconds, then insert the power cable, the battery, and try again.

When that doesn't work, carefully follow these steps;

1.  add battery, power cable, and bring the system to the ok prompt,

2.  check the battery LED is on and green,

3.  check the battery latch is locked,

4.  type "flash-ec! rom:ecimage.bin" and press enter,

5.  observe the consequences.

First, the machine should reprogram the SPI FLASH chip used by the
EC.  Next, it should reboot and the automatic Open Firmware upgrade
will occur.  Finally, it should reboot into 13.2.6.

Let me know how it goes.


On Thu, Jan 21, 2016 at 01:11:25PM -0500, Adam Holt wrote:
> Clarif: XO-4 does not boot anymore, as a result of installing Release 13.2.6
> (oops! wishful thinking!) so machine now attempts to install Q7C05 on every
> boot.  I'm unclear why bootup fails, given the following red warning appears,
> but fyi machine freezes as show:
>    Got firmware version: CL4   Q7C05  Q7C
>    Checking integrity ...
>    Unsafe to update firmware now - EC command result timeout
>     Continuing with old firmware
>    Trying last:\boot\runos4.zip
>      OS found - Trying last:\boot\runrd4.zip
>      RD found - <cursor stuck here, with machine frozen>
> Context: this is Caryl Bigenho's XO-4 demo machine to show off at many
> conferences, an engineering sample John Watlington generously sent to her,
> derived from SKU294, perhaps dangerously so!  But hopefully all hope is not
> lost??  (Certainly it booted until we just tried reflashing to 13.2.6...)
> On Thu, Jan 21, 2016 at 5:23 AM, Adam Holt <[1]holt at laptop.org> wrote:
>     I'm trying to help someone upgrade their XO-4 Touch to the latest firmware
>     (Q7C05) but this isn't working, seemingly blocked by the EC which cannot
>     detect good white batteries inside this XO (each white battery's we tried
>     is fully charged, as verified by other XO's).
>     The ok prompt announces this XO-4 has firmware Q7B23 but when running
>     "menu" at the ok prompt, manufacturing tag BV is set to Q7B01 FWIW.
>     When running "watch-battery" at the ok prompt, it responds:
>        EC command result timeout
>     When clicking on battery within [2]http://wiki.laptop.org/go/XO_Self_Test
>     the screen goes all red, showing:
>        Testing /battery
>        Selftest failed due to abort
>     When running "test /battery" at the ok prompt, it responds:
>        No selftest method for /battery
>     Any workarounds or things to try, regardless whether EC (Embedded
>     Controller 0.3.04) or some other hardware issue on this very early XO-4
>     Touch might somehow be to blame?  Thanks for ideas!
>     --
>     Unsung Heroes of OLPC, interviewed live @ [3]http://unleashkids.org !
> References:
> [1] mailto:holt at laptop.org
> [2] http://wiki.laptop.org/go/XO_Self_Test
> [3] http://unleashkids.org/

> _______________________________________________
> Devel mailing list
> Devel at lists.laptop.org
> http://lists.laptop.org/listinfo/devel

James Cameron

More information about the Devel mailing list