XO-4 firmware upgrade blocked by EC 0.3.04 ?

Adam Holt holt at laptop.org
Thu Jan 21 13:11:25 EST 2016

Clarif: XO-4 does not boot anymore, as a result of installing Release
13.2.6 (oops! wishful thinking!) so machine now attempts to install Q7C05
on every boot.  I'm unclear why bootup fails, given the following red
warning appears, but fyi machine freezes as show:

   Got firmware version: CL4   Q7C05  Q7C
   Checking integrity ...
   Unsafe to update firmware now - EC command result timeout
    Continuing with old firmware
   Trying last:\boot\runos4.zip
     OS found - Trying last:\boot\runrd4.zip
     RD found - <cursor stuck here, with machine frozen>

Context: this is Caryl Bigenho's XO-4 demo machine to show off at many
conferences, an engineering sample John Watlington generously sent to her,
derived from SKU294, perhaps dangerously so!  But hopefully all hope is not
lost??  (Certainly it booted until we just tried reflashing to 13.2.6...)

On Thu, Jan 21, 2016 at 5:23 AM, Adam Holt <holt at laptop.org> wrote:

> I'm trying to help someone upgrade their XO-4 Touch to the latest firmware
> (Q7C05) but this isn't working, seemingly blocked by the EC which cannot
> detect good white batteries inside this XO (each white battery's we tried
> is fully charged, as verified by other XO's).
> The ok prompt announces this XO-4 has firmware Q7B23 but when running
> "menu" at the ok prompt, manufacturing tag BV is set to Q7B01 FWIW.
> When running "watch-battery" at the ok prompt, it responds:
>    EC command result timeout
> When clicking on battery within http://wiki.laptop.org/go/XO_Self_Test
> the screen goes all red, showing:
>    Testing /battery
>    Selftest failed due to abort
> When running "test /battery" at the ok prompt, it responds:
>    No selftest method for /battery
> Any workarounds or things to try, regardless whether EC (Embedded
> Controller 0.3.04) or some other hardware issue on this very early XO-4
> Touch might somehow be to blame?  Thanks for ideas!
> --
> Unsung Heroes of OLPC, interviewed live @ http://unleashkids.org !
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.laptop.org/pipermail/devel/attachments/20160121/7b2c477f/attachment.html>

More information about the Devel mailing list