Touch Pad Double tap to select not working

James Cameron quozl at
Wed May 20 02:02:18 EDT 2015

This is called tap to click.  I see same result:

- XO-4 Model SKU301
- Sugar 0.103.2
- build 14.1.0 for XO-4 (build 9)
- firmware Q7C05
- touchpad type "FSPPS/2 Sentelic FingerSensingPad"

I tried using the builder instructions [1] to set register 0x42 to
0x87 but it did not stay set.  It is as if the register is read-only.

I fixed the builder instructions [1] because the "c" to "C" change has
moved into udev instead of olpc-configure.

I checked other documentation [2].

Please use olpc-fsp-fwread on your SKU320 and reply with result?

How many laptops have been tested in SKU326?

Does your SKU320 respond at firmware ok prompt "test /mouse"?

We do not test this feature during manufacturing, because it isn't in
our operating system, and isn't in specifications.


My SKU301 results:

# dmesg | egrep 'psmouse|serio1'
psmouse serio1: sentelic: Finger Sensing Pad, hw: 13.2.6, sn: 0, sw: 1.1.0-K
input: FSPPS/2 Sentelic FingerSensingPad as /devices/d4290000.ap-sp/serio1/input/input9

# /usr/bin/olpc-fsp-regs verify
unexpected readback for 42: 42e7

# olpc-fsp-fwread
Got FSP at /sys/bus/serio/drivers/psmouse/serio1
0x82a5 = 0x05
0x82a6 = 0x12
0x82a7 = 0x90
0x820b = 0x2a
0x820e = 0x2a
0x8215 = 0x64
0x8217 = 0xaa
0x821b = 0x6f
0x8230 = 0xa0
0x8242 = 0xe7
0x8243 = 0x01
0x8245 = 0x21
0x8247 = 0x44
0x8250 = 0x1f
0x8254 = 0x1a
0x825f = 0xcc
0x8264 = 0x63
0x8265 = 0x63
0x8266 = 0x44
0x8267 = 0x66
0x826c = 0xa8
0x826d = 0x8a
0x826e = 0x40
0x827e = 0x0e
0x82ce = 0x02
0x82f0 = 0x3a
0x8339 = 0x0b
0x8350 = 0x1e
0x8351 = 0x1e
0x8385 = 0x00
0x8241 = 0xdf
0x8248 = 0xa3
0x8261 = 0x00
0x8204 = 0x06
0x821a = 0x22
0x821e = 0x14
0x821f = 0x0e




James Cameron

More information about the Devel mailing list