[XSCE] sdcard for /opt and /library on xo 1.5

James Cameron quozl at laptop.org
Tue Jul 14 20:13:40 EDT 2015

G'day Tim,

Thanks, that's interesting.

My best guess is you have a bad connector and the 24-hour thermal test
you did fixed it.  The problem may return.

Another guess is that the card has the production state awareness
feature [1], part of e.MMC v5.0, which uses the storage cells
differently before they are enabled for normal use.  The state can be
changed with suitable tools, or will clear itself once enough data is
written; followed by a power cycle.  The result is a sudden increase
in performance after that power cycle.


- next time you want to erase a card, send it the erase command, which
  takes between three and fifteen seconds in my tests [2],

- test the communications between the system and the card by measuring
  the sequential read performance; this is usually the easiest way to
  test communications,

- try on a different XO-1.5, in case you have a faulty XO-1.5, and
  raise doubts if the performance differs,

- try on a modern desktop system; that will isolate the problem to
  interoperability with the XO-1.5,

- identify the kernel, in case you have a version that doesn't
  properly switch to 1.8V; if so, the slot on the XO-1.5 will run it
  at 3.3V, warm, and so the card firmware will intentionally slow the
  transfers to ensure compliance with thermal specifications,

- try reseating the card in the adapter, and the adapter in the
  system, because a bad connection can show up as slow data rate, then
  re-test the communications,

- if available, use uninit_bg when calling mke2fs, so that the
  "formatting" doesn't have to write much,

- publish the dmesg fragment showing the card being detected.

When thinking about problems with SD card, it is best to imagine it as
a separate computer, in which you can't change the software.  There's
no telling what it will do.  ;-)  They are very complex systems, made
to look simple.  Plug and play, dumbing down.

+CC devel@ for general XO-1.5 and SD card interest.



(but use http://wiki.laptop.org/go/Firmware/Storage#devalias_fsdisk

On Tue, Jul 14, 2015 at 06:34:52PM -0400, Tim Moody wrote:
> I have been around the block with a 128G micro sdcard allegedly from
> Sandisk.  I made various attempts at creating two partitions and
> formatting them ext4, some of which progressed at the rate of
> 10G/hour.
> I finally used dd to write /dev/zero to the entire device, which
> took almost 24 hours.
> After that parted mklabel msdos and mkpart worked fine and mkfs.ext4
> also worked fine in a couple of minutes.

James Cameron

More information about the Devel mailing list